SDDM switch user problem leading to system unable to start


One problem leading to another, I cannot start and log into my Tumbleweed/Plasma/x64 desktop installation.

It started with a problem with SDDM: I could not switch user.
It would only offer every time to log back into the first account used at start up.
This happened over months, despite several full updates (zypper dup).

I thought about trying a different dm until I could fix the SDDM one or to see if SDDM was actually the cause, and installed gdm, then changed with “update-alternatives --config default-displaymanager” in console.
But now the system stops during the start up and I am stuck.

The system is installed on one full drive with LVM.
Boot / Grub works fine, I can select openSuse or previous kernels > but no better luck using any of them.
After that step, it stops, black screen, and I have a good guess that it is asking for the drive password: I can see the computer work and use the drive further only if I type it correctly.
And it stops there after a few seconds of working.

I tried to boot to console, adding “3” at the end of the boot line, with the intent of setting back the dm to be SDDM, but I cannot ever get to a console prompt.
I can boot from a Kubuntu installation on the same computer, different drive, and I can mount the first drive to access to the system. I thought about trying to modify something manually to set the dm back to SDDM, but I cannot figure out how.

Would you have some tips about what to do?

Which password? You never mentioned anything about encryption when you described your configuration.

Anyway. booting with plymouth.enable=0 added to and quiet removed from kernel command line may give some more information.

I cannot reproduce it. I did “Switch user” from the KDE menu (no idea how it is called “officially”) when running as auto-logged-in user. I got SDDM login screen with user list; currently logged user was “preselected” (highlighted) but I could select other user and login. You probably need to provide more detailed description (including screenshots) what you see.

You may post messages of sddm from current boot by running journalctl --identifier sddm -b as root.

I found the solution:

  • I mounted the encrypted system from the Kubuntu one with cryptsetup
  • looking at logs I found /var/log/alternatives.log
  • in it, I saw “/usr/lib/X11/displaymanagers/default-displaymanager” a symlink to another symlink “/etc/alternatives/default-displaymanager”
  • that last symlink pointed back at “/usr/lib/X11/displaymanagers/gdm”.
  • so I modified that symlink to point back at sddm: "sudo ln -sfn /usr/lib/X11/displaymanagers/sddm default-displaymanager

I can now boot again into my system :slight_smile:
and even better, the user switch works again… :smiley:

So in the end, it really seems that there is something wrong using gdm on tumbleweed on my system.
I could try again some tests, but they are tidious, I would need first to understand what log or data to search for a bug report.

I’ll keep trying the user switch before considering this solved.

Thank you arvidjaar and karl for your replies,

  • Yes, my system drive is encrypted: LVM+luks+btrfs
  • I cannot either reproduce the SDDM user switch problem on another computer that also runs tumbleweed. But I actually found another issue on that system (I cannot relog to the first user), I will report this separately.
  • I mentioned that I could never get to a console prompt, but now I can, the only yellow/warning I can see was:
sudo journalctl --identifier sddm -b
avril 02 22:50:25 opensuse-desktop sddm[1538]: Setting default cursor
avril 02 22:50:26 opensuse-desktop sddm[1538]: Could not setup default cursor

I’ll note that I use GDM to login to KDE (including with Tumbleweed). So the problem might indeed be specific to your system. Perhaps it doesn’t like your graphics card.