sddm on high res dsiplay


my notebook monitor is 2560x1440 on 14 inch

I tried it with adding

ServerArguments=n -nolisten tcp -dpi 144

into my /etc/sddm
but this has no effect,
everything is still very small

on the first login, later, when I shall add the password to unlock the screen it looks OK

How can I improve this?

Don’t change the dpi.
In your Desktop Display settings change the <screen resolution>.


Do you mean the the SDDM login screen itself? Or the KDE desktop? This could be due to the display not reporting the EDID properly.

Anyway for the login screen with an HiDPI display, you could try using


and perhaps try setting the display size explicitly with a custom Xorg configuration eg /etc/X11/xorg.conf.d/80-monitor.conf

Section "Monitor"
    Identifier "Default Monitor"
    DisplaySize 310 174
  • Just an example.

For the KDE Plasma 5 desktop itself, this archlinux page might be helpful to you. Essentially scaling the desktop and/or effective DPI to suit. (I would not recommend changing the display resolution for any thing other than the native resolution.)

EnableHiDPI=true in /etc/sddm.conf had no effect

as said, KDE is nice, it is just the very first login screen, or when I am locked out

so a pure sddm thing.
it seems sddm seems to ignore everything I add into its config :frowning:

Try adding the desired DPI to the ‘[XDisplay]’ section of sddm.conf eg

ServerArguments=-dpi 192

Then restart the X-server.

it looks like the root (default) resolution/dpi is different then the user chooses
happened to me on my old monitor I’d say if an nvidia card run nvidia-settings as root and save your resolution/dpi or set your resolution manually as deano_ferrari said or in /etc/X11/xorg.conf (depreciated but still works)

if it happens on the lock screen too it’s definitely sddm related just keep in mind if editing /etc/sddm.conf
an update will most likely remove your edit, I edited it to enable Num Lock but an update removed it

works excellent, and KDE applies this setting also if no use defined dpi is selected in the control center


Thanks for the update. :slight_smile:

in Leap 15, what I just installed, I copied the


(was it exactly called like this? anyhow) file to
/etc/sddm.conf.d/and added the ServerArguments=-dpi 192

arguments there , than it worked