sddm not starting

Did not solve the problem :frowning:

No success :frowning:

Well, does it help if you add the user “sddm” to the video group?

sudo usermod sddm -G -a video

The greeter normally runs as user “sddm”. As it works when you run it as your user, it may be a permissions problem.
(in particular as you disabled kernel mode setting)

Also no success :frowning:


linux-aqyn:~ # usermod sddm -G -a video
usermod: group '-a' does not exist

Something went wrong…

usermod -G video -a sddm

works

I did not disable anything, as i know…

Did not solve my problem :frowning:

if i set xdm it works well… there is something wrong with sddm and my (hardware-)config i think… :frowning:

No i tested with different versions of sddm:

0.14 works
0.15 works
0.17 not working

Now i have to find 0.16 and see with which version the problem begins. Maybe we will see something in the changelog of sddm …

Can not find a rpm with version 0.16. Was there never a Suse-Release with 0.16?

Or “usermod -a -G video sddm”.
Sorry about that.

I did not disable anything, as i know…

You boot with the “nomodeset” kernel parameter, which disables kernel mode setting.

No.

There has been a major change to how the configuration is handled in 0.17 though.
So maybe try to rename or delete /etc/sddm.conf.

You could also look at the journal whether sddm prints some indication to the problem there.
You can read the journal with “journalctl”, I’m not sure at the moment how to extract sddm’s output only though.
Maybe something like “journalctl|grep GREETER”?

No problem.

Oh yes… i did that because first i tried with nvidia Geforce 7600GS which also failed. I gave up because the driver is not compatible to Kernel 4.16. Do you think that could be a problem?

The installation was fresh an the only version which was installed was 0.17. So the sddm.conf was the default. After the boot failed i tried with different versions. But i will try it. Does not hurt :wink:

Thanks for the hint. I will generate a clean log tomorrow. Now its Ghost-Time (Time is 0:00am). I have to go to sleep. Thanks a lot for your help!