sddm lock after entering password

Hello,

I installed the snapshot 20210609 today but thereafter I cannot login in sddm: Selecting an user and entering the password doesn’t start kde. The sddm screen remains without activity
In journalctl I see only

Jun 11 15:52:15 hpprol2 sddm[5833]: Invalid session "/var/lib/sddm/.desktop" 

process running for sddm are

ps -ef | grep sddm
root      5833     1  0 15:58 ?        00:00:00 /usr/bin/sddm
root      5835  5833  0 15:58 tty7     00:00:01 /usr/bin/Xorg.bin -nolisten tcp -auth /run/sddm/{5edaa53b-4460-4766-b7c7-dcce32aa1ddb} -background none -noreset -displayfd 17 -seat seat0 vt7
root      5854  5833  0 15:58 ?        00:00:00 /usr/libexec/sddm/sddm-helper --socket /tmp/sddm-authc711ea7d-16b9-4be6-87f2-6866263ca4b2 --id 2 --start /usr/bin/sddm-greeter --socket /tmp/sddm-:0-PvQrvE --theme /usr/share/sddm/themes/breeze-openSUSE --user sddm --greeter
sddm      5856     1  0 15:58 ?        00:00:00 /usr/lib/systemd/systemd --user
sddm      5857  5856  0 15:58 ?        00:00:00 (sd-pam)
sddm      5866  5854  0 15:58 ?        00:00:02 /usr/bin/sddm-greeter --socket /tmp/sddm-:0-PvQrvE --theme /usr/share/sddm/themes/breeze-openSUSE
sddm      5869  5856  0 15:58 ?        00:00:00 /usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
root      6021  2556  0 16:13 tty1     00:00:00 grep --color=auto sddm

in /var/lib/sddm there is no file or directory .desktop.
I can login with the users in a console.
I forced a reinstallation of sddm without succes even after reboot.

Any idea where to look?
regards
Philippe

Things to try:

Is it just for this user? Have you tried a different user (create one if necessary)?

Can you start a different kind of login session - not KDE? (The bottom left of the sddm screen normally offers a choice of session types.)

Same problem with an other user and also with a new user.
I saw that the choices for sessions (plasma X11, full wayland or plasma wayland) were missing in sddm screen. So I forced a reinstall of plasma-session and this solved the problem.
Could not find the reason why this occurred . Not sure that it is related to the snapshot.

Regards
Philippe