sddm failure on boot, caused by SAX3?

This is already solved, but I wanted to see if someone could verify my theory as to what caused it, or otherwise comment.

I booted today to get dumped at a command line prompt.

Now this may or may not be related to the sddm issue but there was an error Failed to start service enabling compression RAM with zRam. I did a bunch of searching and eventually found this: I applied the suggested changes to /usr/lib/systemd/system/zramswap.service and that resolve that.

But then it still booted to command line, this time with no obvious error at the end. joiurnalctl turned up sddm errors:

Failed to read display number from pipe
Could not start Display server on vt 7

After a bunch of searching I began to wonder if what caused my problem was having run SAX3 recently. Had no idea what I was doing, I just ran it via a mis-click in the launcher menu. I wondered if it had messed up my graphics card or display configuration. Non of the threads discussing the error quite matched my situation, but one suggested running startx and seeing what errors came up. I tried that and it complained about a syntax error in /etc/X11/xorg.conf/99-saxtouchpad.conf. So I was like “Aha! SAX!” thinking this file had been newly added by SAX3. It was indeed newly modified. So I renamed that file and can now boot to my normal graphics desktop.

Am I right to blame SAX3?

Could the zram thing be related or is this just coincidental that it cropped up at the same time. I’m pretty sure I’d booted successfully since the last time I updated anything other than running SAX3. Would that error have been non-fatal and not noticed if sddm worked?


I haven’t even heard it mentioning since ~10 years (or do I exaggerate?). Does it really still exist?

To answer my last question, yes it is in the repos, but not installed.

Is there still any use for it?

I searched a bit through the forums and found that in 2010 someone using openSUSE 11.3 already talked bout “the post SAX area”. So those 10 years is pretty near. :frowning:

The stuff I found making me concerned that having run it had caused my problems were all postings / news about SAX2 essentially being long deprecated. At the time I remembered the thing I clicked as being SAX#, but actually it was SAX3. When I did a quick search, what I found made me think maybe SAX3 was still in use, but I looked again after seeing the reactions here and find a Github project, last touched in 2014.

SAX3 got installed in my App menus, in the Settings menu along with the KDE System Settings and Yast. I didn’t explicitly install it, it must have came with the original installer I ran maybe 6 months ago (which was Gecko).

I’m going to take all this as a “Yes, not surprising SAX3 f’ed up something…”