sddm and/or the display-manager service won't try to start X after update


I’ve received a kernel update today which installed version 5.10.16-1 (the previous version I had was 5.10.12-1). Booting this kernel results in my graphical session not starting. This does not seem to be a driver problem since running startx in the virtual tty (when logged in as root) starts a graphical session for root.

When I boot the previous version of the kernel, everything still runs fine automatically, and when I run systemctl status I can see that the display-manager service started sddm and X :

             │ ├─1277 /usr/bin/sddm
             │ └─1310 /usr/bin/Xorg.bin -nolisten tcp -auth /run/sddm/{f848d90b-736b-4b11-83fa-d13b9a495296} -background none -noreset -displayfd 17 -seat seat0 vt7

However, when I boot the new kernel, only sddm appears under the display-manager service. Xorg is apparently not started, and no log is generated in /var/log/Xorg.0.log.

So my guess is that something in sddm or the display-manager service does not start X as it should. Could you please give me some advice on the way to troubleshoot this?


cat /var/log/Xorg.0.log

Maybe you already had kernel 5.10.16-1.2 on your system? It was uninstalled as part of the upgrade.
Some people reported this problem went away when they reinstalled packages from the NVIDIA repo. For me it worked reinstalling kernel 5.10.16-1.3.

You were right, this had something to do with the nVidia packages. There was an update available this morning which contained only 4 nvidia packages. It fixed my setup, X is now starting again using the default boot option.

For reference, here is the nvidia packages install history :

cat /var/log/zypp/history | egrep '\|(install|remove)' | egrep nvidia
... cutting older stuff ...]
2021-02-05 06:50:41|install|kernel-firmware-nvidia|20210119-1.1|noarch|||80517746cd148d9a4cdc086eefa5a81be543038ae042166bc5dbe31047e8cd78|
2021-02-05 06:53:11|install|nvidia-gfxG05-kmp-default|460.39_k5.10.9_1-34.1|x86_64||NVIDIA|91943ab5753f4673b65893676bc4ce275acd251a6fbf02da04bd0636f80396a0|
2021-02-05 06:53:12|install|nvidia-computeG05|460.39-34.1|x86_64||NVIDIA|619da558b815d1795e16730ac20e75bb77879760c9f6ccfb69dd67243b24999f|
2021-02-05 06:53:13|install|nvidia-glG05|460.39-34.1|x86_64||NVIDIA|0736776d735db2e56868871c6f80d8e932078e47b7616ce7f256e1b57bd99da0|
2021-02-05 06:53:17|install|x11-video-nvidiaG05|460.39-34.1|x86_64||NVIDIA|30a88519167aa6f0e21f44367f3e20f53ed8ffe8dfe178a0ee0445d13d180969|
2021-02-19 09:02:48|install|kernel-firmware-nvidia|20210208-1.1|noarch|||7d7fedb16da9256dcf9f33042e0897a0f22f0b338093471a266ecf4724ae1059|
2021-03-01 08:19:18|install|kernel-firmware-nvidia|20210208-2.1|noarch|||5dfef319e1ef6f17685daae3a5e004327255e9dc100e7516ef22d80bd0f21e3b|
2021-03-02 07:03:13|install|nvidia-gfxG05-kmp-default|460.56_k5.10.16_1-35.1|x86_64||NVIDIA|016df39ab56bb43f35df160726c954ca6729a7f053804e657fe170028b4657fb|
2021-03-02 07:03:14|install|nvidia-computeG05|460.56-35.1|x86_64||NVIDIA|341f283fe457a57c057d00f332561b349341538e47d9f63af2990e06c80d2cdb|
2021-03-02 07:03:15|install|nvidia-glG05|460.56-35.1|x86_64||NVIDIA|4cc03a232d2c137072fcb75614422adc58647e78e9c437bdb2ae86ef9b5a640d|
2021-03-02 07:03:19|install|x11-video-nvidiaG05|460.56-35.1|x86_64||NVIDIA|61d1b3ed78c643b00f4a180a19a8813722c6e7c50965135184b1c770e4b131ce|

So the update that broke my setup yesterday shipped kernel-firmware-nvidia 20210208-2.1, which may have to do with the bug. Here are also the last kernel updates :

linux:~ # cat /var/log/zypp/history | grep -E '\|kernel-default\|' | cut -f 1-4 -d'|'
... cutting older stuff ...]
2021-02-05 06:54:10|install|kernel-default|5.10.12-1.2
2021-02-05 06:57:09|remove |kernel-default|5.10.7-1.2
2021-02-19 09:04:19|install|kernel-default|5.10.16-1.2
2021-02-19 09:15:55|remove |kernel-default|5.10.9-1.2
2021-03-01 08:19:11|remove |kernel-default|5.10.16-1.2
2021-03-01 08:20:05|install|kernel-default|5.10.16-1.3