SDDM and Autologin (2024 update)

I wanted to give an update on SDDM and Autologin (which is now closed, unfortunately)

For me, using up-to-date TW, sddm autologin with KDE6 and Wayland is still broken. If autologin is configured, I get a black screen. Restarting sddm fixes the issue. Manual login to Wayland KDE works as well. This is reproducible on two TW machines, one with Intel, one with AMD GPU.

I don’t have the issue with other distributions, could be luck (since it’s probably a race condition as mentioned in the initial thread from last year) or could be a TW specific issue. Do others see a similar behavior or have a solution for it?

https://bugzilla.opensuse.org/show_bug.cgi?id=1221507

In the linked bugzilla issue 1221507, there’s a link to an upstream draft Always use VT_OPENQRY by Vogtinator · Pull Request #1896 · sddm/sddm · GitHub which mentions a bugreport in systemd ttys not claimed by getty even when getty.target is up · Issue #31909 · systemd/systemd · GitHub

The proposed fix of @Vogtinator to change Type=idle to Type=exec in getty@.service indeed changes the behavior: I now get at least a tty when doing sddm autologin into wayland. However still no proper login. Before, I just got a black screen (from which I had to manually switch to a tty with ctrl+alt+)

I can then login in the tty and call systemctl restart sddm and I have a proper graphical desktop.

looking at journalctl, I see as last entry before stopping the graphical target: “pam_kwallet5: Couldn’t get password (it is empty)”. Could that be related?

Mai 06 21:35:46 nii systemd[1]: NetworkManager-dispatcher.service: Deactivated successfully.
Mai 06 21:35:47 nii login[1705]: pam_kwallet5(login:auth): pam_kwallet5: pam_sm_authenticate
Mai 06 21:35:47 nii login[1705]: pam_kwallet5(login:auth): pam_kwallet5: Couldn't get password (it is empty)
Mai 06 21:35:48 nii systemd[1]: Stopping User Manager for UID 1000...
Mai 06 21:35:48 nii systemd[1945]: Activating special unit Exit the Session...
Mai 06 21:35:48 nii systemd[1945]: Stopped target Main User Target.
Mai 06 21:35:48 nii systemd[1945]: Stopped target plasma-workspace-wayland.target.

its not, I’m struggling with the same issue, and literally tried out everything, but nothing seems to help. To clarify, I have a testing computer, with an nvidia card in it, using G06 propietary drivers, and tumbleweed (of course sddm / plasma) and the sddm autologin works.

On my main computer (almost same setup) the autologin does not work, and for context I never had any issues with sddm wayland autologins on other distros. I’ve wasted 2 days of figuring out what is causing this, to no avail… It seems its TW related (again saying this because I’ve got it proovenly working on other distros) . I think I’m gonna try out Leap, when I got energy to do it so…

Today I gave it a try to remove all the proprietary nvidia drivers to set it back to default nouveau: Wayland autologin works BUT its stuttering and ultra laggy…

So to summarize:
sddm + wayland + autologin + proprietary nvidia drivers = black screen
sddm + wayland + autologin + nouveau nvidia driver = unusable slow / lagging / stutter

System info

Operating System: openSUSE Tumbleweed 20240531
KDE Plasma Version: 6.0.5
KDE Frameworks Version: 6.2.0
Qt Version: 6.7.1
Kernel Version: 6.9.3-1-default (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-6500 CPU @ 3.20GHz
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
Manufacturer: MSI
Product Name: MS-7972
System Version: 2.0