SDB says nouveau is blacklisted when Nvidia drivers installed. Not for me.

What is the file I’m supposed to edit to blacklist nouveau? I installed the latest Nvidia drivers and the only way I can get them to load is to add ‘nomodeset’ or ‘initcall_blacklist=nouveau’ to the boot parameters. And apparently nouveau can’t be deleted because of Mesa. I know I can make the initcall parameter permanent, but I’d rather just blacklist nouveau.

/etc/modprobe.d/50-blacklist.conf

Here you go…

https://en.opensuse.org/SDB:NVIDIA_the_hard_way#Blacklist_nouveau
https://support.huawei.com/enterprise/en/doc/EDOC1100165479/93fe5683/how-to-disable-the-nouveau-driver-for-different-linux-systems

Here is the content of the modprobe file:

cat /etc/modprobe.d/50-nvidia.conf

generated by nvidia-installer

blacklist nouveau
options nouveau modeset=0

The part about it generated by nvidia-installer is false, at least in my case.

Despite me having this file, if I don’t one of the parameters I posted above, Nouveau always loads instead of nvidia.

The link that deano provided says I’m supposed to let the installer create a config file but the default selection is always ‘No’. Am I supposed to do that every time or just the first time?

The file is fine, you have to

mkinitrd

After writing and saving that file, then reboot.

That’s what I did. And I saw text going by the contained ‘modprobe nvidia.conf’.

Hi
What is the Nvidia card, what version of the driver?

Show us the output from

inxi -Gxx
localhost:~> inxi -Gxx 

**Graphics:  Device-1:** NVIDIA GP106 [GeForce GTX 1060 6GB] **vendor:** ASUSTeK **driver:** nvidia **v:** 510.68.02 **bus-ID:** 09:00.0 
           **chip-ID:** 10de:1c03 
           **Display:** x11 **server:** X.Org 21.1.3 **compositor:** kwin_x11 **driver:****loaded:** nvidia **unloaded:** modesetting 
           **failed:** fbdev,vesa **alternate:** nouveau,nv **resolution:** 3840x2160~60Hz **s-dpi:** 162 
           **OpenGL:****renderer:** NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 **v:** 4.6.0 NVIDIA 510.68.02 **direct render:** Yes

The only reason the nvidia driver is loaded is because I changed the boot parameters as I described above.

Boot without this boot parameter and provide full output of “journalctl -b” immediately after boot.

# inxi -GISaz
System:
  Kernel: 5.17.5-1-default arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    **parameters: root=LABEL=<filter> vga=791 video=1440x900@60**
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.2 wm: kwin_x11 vt: 7 dm: KDM
    Distro: openSUSE Tumbleweed 20220510
Graphics:
  Device-1: NVIDIA GT218 [GeForce 210] vendor: eVga.com. driver: nouveau
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 ports:
    active: DVI-I-1,HDMI-A-1 empty: VGA-1 bus-ID: 01:00.0 chip-ID: 10de:0a65
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting failed: fbdev,vesa alternate: nouveau,nv,nvidia
    gpu: nouveau display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 120 s-size: 948x304mm (37.32x11.97")
    s-diag: 996mm (39.19")
  Monitor-1: DVI-I-1 pos: primary,left model: Acer K272HUL serial: <filter>
    built: 2018 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-1 pos: right model: Samsung built: 2009
    res: 1920x1080 hz: 60 dpi: 305 gamma: 1.2 size: 160x90mm (6.3x3.54")
    diag: 184mm (7.2") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  OpenGL: renderer: NVA8 v: 3.3 Mesa 22.0.3 direct render: Yes
Info:...Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15

A bit better information from a instead of xx, and adding S.

When I booted this morning, the Nvidia driver loaded. So I’ll guess I’ll keep my eye on it.

I’m on Leap 15.3, kernel 5.3.18-150300.59.68-default…

Upon booting up this morning, nouveau was active, even though I had been booting up on NVIDIA drivers. I did do a kernel update yesterday, which required a reboot, but not a complete shutdown and power up, which sometimes makes a difference with graphics, at least as I’ve observed…

I rebooted and added “nomodeset 3” to Grub, to allow me to reinstall the NVIDIA driver the hard way. Reboot again didn’t change anything, still nouveau.

I went looking around for a thread here…

  1. /etc/modprobe.d/50-nvidia.conf was missing(!) [There was another file with blacklist nouveau, that the NVIDIA installer pointed out, with a different path, but I forgot to jot it down. It was the single file in its directory.]
  2. I recreated from info found in post above
  3. mkinitrd
  4. reboot didn’t change anything
  5. shutdown, then power up… back to normal

I’m not sure how my 50-nvidia.conf file was missing.