SCSI flatbad scanners?

I’m not sure hardware is the best sub-forum for this. Multimedia may be a good one too, but since it involves specific hardware I figure this may be appropiate.

Anyway, I recently got hold of an older flatbed scanner. An AGFA Snapscan1236 to be precise. It’s connected to an older Adaptec SCSI-card: an AHA-2940. The computer runs openSuse 11.3, 64bit with KDE 4.4.4.

The combination works fine, and I get as good scans as one could expect of a 600 DPI-scanner - but only if I remember to turn on the scanner before I boot the computer. If I forget that, the scanner software (including Yast’s “Configure scanner” module) refuses to recognize there’s a scanner present. I’ve tried with KDE’s AquireImages (part of the KIPI-plugins, I believe) and xsane with the same result.

Is there a way round that?

When you plug in your SCSI scanner, what is reported via

dmesg |tail

I would have thought these devices would have been dynamically detected. Anyway, to rescan the SCSI bus manually, you can type

Then try


A different approach:

I thought they would be dynamically detected too. Anyway,

dmesg reveals nothing relating to SCSI whatsoever. In fact, after a fresh boot with the scanner turned off then turned on as soon as I logged in turns out nada with dmesg that wasn’t related to the boot-up process.

However, the rescan-scsi-bus script (thanks for that! didn’t know of it), revealed a possible culprit. I got a lot of “permission denied” when it was probing the adaptec-card when run as an ordinary user. When run with sudo it worked. I can only come to the conclusion (maybe erroneously) that’s why the scanner isn’t dynamically detected. Once the script had run, the scanner was found as it should even with my ordinary credentials.

Will try the hints in the link you provided tomorrow (middle of the night here right now…).

Okay, so I’ve tried the other methods as well. Turned out the shell-script was the most reliable solution. Not an ideal solution to be sure, but at least it works. Especially when you set up a custom sudo-rule so you don’t have to enter a password just to get the scanner to work.

Thanks a lot for your help!

Yes, I’m surprised that hal/udev doesn’t handle your scsi scanner device automatically. I must admit, I don’t have removable scsi devices to play with.

Neither do I, apart from the scanner so I don’t know if the same applies to say tape streamers but the link you provided seems to indicate it does. Unfortunately, I have no way to verify it.

Still, it should (I think) be possible to write a custom udev-rule to handle it but that’s way out of my league.

Turned out the shell -scrit was…
Where can I find this script to start to get my hp6100C working again.