Scsi DVD RAM not working on SuSE 11.4

I installed OpenSuse 11.4 (x86_64) a couple of days ago.

One of my Drives a PC-DVD RAM (Creative) is not working. This worked under 11.3.

The SCSI drive is connected to a PCI/SCSI adapter (AHA-2904).

The message I see at boot is:

ata_id[443]HDIO_GET_IDENTITY FAILED /dev/sr1

I also see the message ata_piix not found, and can not find an option in the kernel
to provide this.

This causes the system to wait a long time and slows down boot dramatically!!

I would appreciate any help to solve this problem


So, after doing some searching it seems that the Adaptec AHA-2904 is using the AIC7xxx chipset. This is set in the Linux Kernel to be compiled as an optional module. So, since it may be considered legacy, it may now be left out of the standard compile when using the 2.6.37 kernel. It is possible to compile your own kernel, but it is kind of hard to describe how to change the kernel compile option. I am unclear if you do a compile on your system if the Adaptec board will be detected and therefore add in the support automatically OR if you need to add the support manually by configuring your kernel. I popped up the latest kernel, brought up the kernel configuration in my BASH script SAKC and found the option as:

Device Drivers ---> SCSI Device Support ---> SCSI Low-Level Drivers ---> Adaptec AIC7xxx support (old Driver) OR Adaptec AIC7xxx Fast - U16 Support (new driver)

Both of these options are set to Module (M). Module means add support at compile time, but based on what is the question? Either can be set to “*” which means add support. I don’t know what the actual problem is, but if you want to play with adding in this support you can give it a try by enable these functions one at a time and compiling the kernel. In the end, it could even be a waste of time for you. Here is the sakc bash script file to compile a kernel.

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.00

Message #17 has the most recent version of sakc and message #22 has the most recent version of klist, a support script file for sakc. You can find the most recent version of kernel here:

I know that this is not a simple fix, but I am other wise not sure how to help with this card. A simple direct SATA connection is a better way to go if your computer supports the interface.

Thank You,

Hi , Thanks for the suggestions. I tried both the new aic7xxx and aic7xxx_old drivers, as suggested, but they both generate the same message:

Looking at the kernel boot messages with ‘dmesg’, the drive is recognized

The first drive sr0 (scsi3-mmc drive: 15x/15x writer dvd-ram cd/rw) is fine!

[17.307208] scsi 2:0:4:0: CD-ROM CREATIVE DVD-RAM RAM1216S 1311 PQ: 0 ANSI: 2 CCS
17.307226] scsi target2:0:4: Beginning Domain Validation
17.314601] scsi target2:0:4: FAST-10 SCSI 10.0 MB/s ST (100 ns, offset 15)
17.318779] scsi target2:0:4: Domain Validation skipping write tests
17.318782] scsi target2:0:4: Ending Domain Validation

and further on in the log:

26.669796] sr0: scsi3-mmc drive: 15x/15x writer dvd-ram cd/rw xa/form2 cdda tray
26.669801] cdrom: Uniform CD-ROM driver Revision: 3.20
26.670314] sr 1:0:1:0: Attached scsi CD-ROM sr0
26.679502] sr1: scsi3-mmc drive: 0x/0x dvd-ram cd/rw xa/form2 cdda tray
26.679938] sr 2:0:4:0: Attached scsi CD-ROM sr1
26.729437] sd 0:0:0:0: Attached scsi generic sg0 type 0
26.729535] sd 0:0:1:0: Attached scsi generic sg1 type 0
26.729626] sr 1:0:1:0: Attached scsi generic sg2 type 5
26.729712] sr 2:0:4:0: Attached scsi generic sg3 type 5

Then later:

27.371854] (scsi2:A:4:0): No or incomplete CDB sent to device.
27.371949] scsi2: Issued Channel A Bus Reset. 1 SCBs aborted

Seems as though their may be a driver problem causing this message with the second drive (sr1) “No or incomplete CDB sent to device”.

Does anyone have the forum for driver bugs?