Scrool in Firefox is very slow with desktop effects enabled

Hello everyone. I am using openSuSE 11.2 Factory ( i know is dangerous and i am also a beginner , but i pay attention on every update … anyway ).
I have a problem with Firefox and desktop effects enabled.
My video card is a ATI and using the opensource radeon drivers. Now. Every time i enable desktop effects everything works very well except the scroll in Firefox wich is very very slow. This happend in opensuse 11.1 also.
Does anyone know a workaround for this ?
I have also filed a bug ( my first one ).
Be gentle to me :wink: thank you !

You need to provide more detail about your machine, video card and driver. Card model, driver install method and version, _64 or x86 etc…

Then the ATI boffins can advise.

Hello. Ok i will provide more Info:
So my video card is ATI Xpress 1100 and am am using the opensource driver that is in opensuse 11.2 The hardware architecture is 64 bit.

Disable smooth scrolling in the tools/options/advanced settings. It should solve the problem.

ok i will try that.

I know this thread is a little older, but this fix appears to have worked for me… Thanks!

The real problem is that the open source drivers do not support 3D accelleration, or at least not in full. And AMD/ATI is not going to do anything about it, since yours is a “AMD/ATI declared legacy” one.