Scriptlet fails updating ImageMagick

I’ve installed Slowroll and testing it for a couple of weeks now (in a VM, host machine is a TW install).

I’ve had this persistent problem with an update (removal?) to ImageMagick.

Here’s the dup output - first I respond with Retry, then Ignore

  zypper-log               1.14.68-4.4 -> 1.14.70-1.1.6.1                noarch  update  openSUSE
  zypper-needs-restarting  1.14.68-4.4 -> 1.14.70-1.1.6.1                noarch  update  openSUSE

The following package is going to be REMOVED:
  ImageMagick-config-7-SUSE  7.1.1.26-1.3  x86_64  openSUSE

18 packages to upgrade, 1 to remove.
Overall download size: 5.2 MiB. Already cached: 0 B. After the operation, additional 25.7 KiB will be used.
...

Retrieving: lvm2-2.03.22-3.3.x86_64 (update)                                                       (18/18),   1.5 MiB
Retrieving: http://cdn.opensuse.org/update/slowroll/repo/oss/x86_64/lvm2-2.03.22-3.3.x86_64.rpm .......[done (2.2 MiB/s)]

Checking for file conflicts: ......................................................................................[done]
update-alternatives: error: no alternatives for ImageMagick-7
error: %prein(ImageMagick-7.1.1.29-10.1.x86_64) scriptlet failed, exit status 2
error: ImageMagick-7.1.1.29-10.1.x86_64: install failed
error: ImageMagick-config-7-SUSE-7.1.1.26-1.3.x86_64: erase skipped
error: ImageMagick-7.1.1.26-1.3.x86_64: erase skipped
( 1/18) Installing: ImageMagick-7.1.1.29-10.1.x86_64 .............................................................[error]
Installation of ImageMagick-7.1.1.29-10.1.x86_64 failed:
Error: Subprocess failed. Error: RPM failed: Command exited with status 1.

Abort, retry, ignore? [a/r/i] (a): r
update-alternatives: error: no alternatives for ImageMagick-7
error: %prein(ImageMagick-7.1.1.29-10.1.x86_64) scriptlet failed, exit status 2
error: ImageMagick-7.1.1.29-10.1.x86_64: install failed
error: ImageMagick-config-7-SUSE-7.1.1.26-1.3.x86_64: erase skipped
error: ImageMagick-7.1.1.26-1.3.x86_64: erase skipped
( 1/18) Installing: ImageMagick-7.1.1.29-10.1.x86_64 .............................................................
[error]
Installation of ImageMagick-7.1.1.29-10.1.x86_64 failed:
Error: Subprocess failed. Error: RPM failed: Command exited with status 1.
Abort, retry, ignore? [a/r/i] (a): i
( 2/18) Installing: crda-4.15-2.1.x86_64 .....................................................
... 
[done]

Hi :smile:

This is an old problem from TW that trickled down to SR.
It can be solved by:

sudo zypper rm ImageMagick-config-7-SUSE
sudo zypper in ImageMagick
1 Like

Thanks - marked as Solved.

I did a search only in here for Slowroll. I even downgraded the three Image* packages back to their first available version, then did another dup, but same issue.

SR is bug-for-bug compatible with TW but with the added benefit of skipping some problematic updates in the middle, I’ve had good luck so far troubleshooting issues for SR in the TW section of forums as it has long been discussed there :wink:

This is 1220818 – ImageMagick and ImageMagick-config-7-SUSE file conflict

1 Like

Thank you very much for creating/maintaining Slowroll :100::handshake:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.