Scriplet Failed, Signal 11 when trying to update packages in Yast.

I’m running OpenSuse 11.1 (this may be the thing that causes me to finally update rotfl! ) with KDE 4.4 (specifically, 4.4.4 release 5).

Recently (maybe the past month or so… give or take a week or two or so… first time I really remember it happening is when I realized they changed the repository for KDE 4.4 from factory to stable and switched them) >90% of the things I try to install via YAST fails with the following error… this example is me trying to upgrade avidemux from the Packman repository.

Error: RPM failed: warning: /var/cache/zypp/packages/Packman_Repository/x86_64/avidemux-2.5.3-4.pm.5.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 9a795806 error: %post(avidemux-2.5.3-4.pm.5.1.x86_64) scriptlet failed, signal 11

Oddly enough, the main avidemux package threw the error, but the avidemux-qt4 package didn’t.

I’ve tried doing
rpm --rebuilddb
but that didn’t help.

I cannot uninstall anything that this error happened to, trying to do so provides this error

Subprocess failed. Error: RPM failed: error: %postun(webkam-0.3.2-1.10.x86_64) scriptlet failed, signal 11

Also, I just now noticed that yast reports that I have both the old and the new version installed, even though it supposedly failed and I aborted.
I just checked, avidemux is reporting that the install completed, as trying to launch the GUI version failed and the cli version showed it was updated. Once I tried to install the qt4 package, launching the GUI version succeeded.

If anyone has any ideas or wants any additional information, let me know.
Thanks

as su -

rpm -e webkam

I did that and it complained about “webkam” being multiple packages, so I added “–allmatches” to it and I received…

error: %postun(webkam-0.3.2-1.10.x86_64) scriptlet failed, signal 6

I did some searching and found this post, which led me to do “/sbin/ldconfig -v” which spewed out some errors about missing directories.
I tried adding the directories, it didn’t complain about them being missing, but it didn’t fix the problem, then I did the “strace -e trace=file /sbin/ldconfig” and found it was aborting when accessing /var/cache/ldconfig/aux-cache, so I moved the file, tried again and it “/sbin/ldconfig -v” didn’t abort.

I just tried to uninstall a program and it completed successfully.

Now I did a “rpm -qa --dupes” to find a list of all packages I accidentally installed twice during this phase so I can reinstall them correctly.

The /sbin/ldconfig -v was “complaining” that some directories (/lib /lib64 /usr/lib /usr/lib64) were listed twice. I checked /etc/ld.so.conf and couldn’t find where they were listed twice. Anyone know about that?

What comes from

zypper --verify

I can’t do that.

I tried and the first thing that happens is it complains about my vlc installation and wants to downgrade my X server (I previously upgraded it, to fix some performance problems I was having with xvidcap and get support for my video card with the radeon driver, via the Xorg repositories, which no longer support 11.1 :\ ) and change the architecture of a bunch of packages from x86_64 to i586.
Now that I think about it, I think I forced an upgrade of vlc (from Packman) since doing so. vlc works fine, but it complains about having the wrong version of “xorg-x11-libs”.

I’m not having any issues with upgrading/installing/uninstalling packages now though. :slight_smile:

This really sounds messy

Can you run Yast - Software Management?

Yeah, I always could, it would just throw an error when trying to install/uninstall/upgrade most packages.

My initial problem seemed to be fixed by moving the /var/cahce/ldconfig/aux-cache file, so I’m assuming it got corrupted somehow.

And to clairify, I can, and did, run “zypper verify” and it complained about “Problem: vlc-noX-1.0.5-1.pm.3.27.x86_64 requires libxcb-keysyms.so.0()(64bit), but this requirement cannot be provided”, the solutions were:

  1. Change architecture on a bunch of packages, downgrade others, remove others, and install yet more, in all it would alter dozens (I’m guessing close to fifty) of packages.
  2. Downgrade xorg-x11-libs.
  3. Ignore the dependency issues.

I canceled out then as I wasn’t about to change 50+ packages and there’s no way I’d downgrade my X server to what comes with 11.1 as it would break xvidcap and I use that all the time.

I did run it again and chose to ignore the dependency issues and the only other complaint it had was it wanted to upgrade “java-1_6_0-sun-plugin” which I did.

Since you mentioned Yast - Software Management, I did the verify system option in there and the only thing it complained about was the same thing as zypper.