screwed up my gnome 2.26 recycle bin


I wanted to change the default gnome recycle bin icon with another one (metal bin from os x which I found in the themes folder of cairo-dock.
There is one icon for an empty bin and one for a full bin.
I first changed the icon for the empty bin, dropped some stuff in the gnome reclycle bin so it changed to a full bin. I then changed that icon to the osx full one (using the right click/properties method in gnome.

So far, no issue, I have my metal bin. But it only shows the empty icon, it never switches back to the full bin.

Result, full or empty, it doesn’t matter, I only see the empty one.
How can I change the empty and full icon so that it also changes according to the situation or how do I get back to the default situation ?


*** bump ***

I imagine you need to copy the icons down into the relevant places
directory down in /usr/share/icons. I use the hydroxygen icon set which
can be installed via the control center. It’s available on

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel
up 12:11, 1 user, load average: 0.25, 0.36, 0.20
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

I’ll give it a try this evening.

Well, I checked the icons folder for the folder containing the icons for the desktop theme I’m using and all is there except the recycle bin icons. I couldn’t find any.

I even installed new themes and switched to one of those and all changed, but not the recycle bin, it remains my own set icons and only the empty one is shown.

I gave up. I removed the icon from the desktop via gconf-editor and switched to the recycle bin from Screenlets. That is the same OS X icon but in Vector format, so I can give it any size I want, it remains sharp and cool. An this one even adds a line below the icon with the number of deleted items it contains.

So I’m ok with this, although I still want to know how to restore the original icon, other people might make the same mistake as I did and may run into the same problems.

OK, solved this one as well… I’m good this weekend, ran into several issue and solved all of them in a coincidence :smiley:

The icons from all the different themes are still in place and yes, I now know where they are and if I replace the original images inside the themes folder they also change on the desktop but you need to be carefull, the full and empty bin are in two different location with the same name, only referred to via a symlink.

But this was not the problem, the problem was that the icon I set up myself as the last one (the empty one) is stored somewhere and I now know where. For those of you running into the same problem :

Inside your home folder there is a .nautilus folder. Below that one are some other subfolders and in one of those folders you’ll find an XML file with a very weird name but containing the word DESKTOP inside.
When I opened this file I saw that it contained the setup of my desktop, that is the list of icons, their size and location on the desktop. If you change the icon yourself, then it’s in this file that it’s stored.

My recycle bin was reconfigured like below (I’ve put the line in blue bold):

<?xml version=“1.0”?>
<directory><file name=“Vista.volume” timestamp=“1241340296” icon_position=“64,342” icon_scale=“1” icon_position_timestamp=“1241340296”/><file name=“trash” timestamp=“1241341546” icon_position=“64,762” icon_position_timestamp=“1241341546” custom_icon=“file:///usr/share/cairo-dock/plug-ins/dustbin/themes/Metal/trashcan_empty.png” icon_scale=“1”/><file name=“home” timestamp=“1241340296” icon_position=“64,102” icon_position_timestamp=“1241340296” custom_icon=“file:///usr/share/pixmaps/gnome-home.png” icon_scale=“1”/><file name=“Data.volume” timestamp=“1241340296” icon_position=“64,262” icon_scale=“1” icon_position_timestamp=“1241340296”/><file name="." timestamp=“1241340296” icon_view_layout_timestamp=“1241340296” window_scroll_position=“x-nautilus-desktop:///network”/><file name=“computer” timestamp=“1241340296” icon_position=“64,22” icon_scale=“1” icon_position_timestamp=“1241340296”/><file name=“network” timestamp=“1241340296” icon_position=“64,182” icon_scale=“1” icon_position_timestamp=“1241340296”/><file name=“PORTABLEAPP.volume” timestamp=“1241196788” icon_position=“64,742” icon_scale=“1” icon_position_timestamp=“1241196778”/></directory>

All I had to do was delete this part in the file :


Save the file, restart nautilus and there was my original icon from the current theme. All I had to do now was replacing the full and empty icons with my own files.
Now it works fine.