Screensaver issues

Hi there.
I was playing around with the screensavers in OpenSuSE 11.2 and found some problems:

  1. Compiz being active make some screensavers not working. It happens with xscreensavers and with kscreensavers too. Mainly those who plays with images or screen captures, like “Distort”, “DecayScreen” and others. You got a blank screen or only part of the image o screen capture, beeing the rest black.

  2. The webcollage screensaver doesn’t work at all. Seems it calls something nonexistent called “collage”

  3. The Media Screen Saver doesn’t work. When launched from the console, here’s the output:

xr@xrdv6:~> kpartsaver.kss
<unknown program name>(19373)/ main: 2 - parseCommandLine
<unknown program name>(19373)/ main: 3 - create KApplication
Unknown Mozilla toolkit (-17978386), assuming toolkit is GTK2
This may cause Mozilla to crash. If it crashes recompile mplayerplug-in with a different toolkit.

The system is up to date. Hardware is HP DV6 2170es, with i5 cpu and nVidia G 230M. nVidia bins are 195.36.15
Kernel is #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64

Any ideas, specially on the weird behaviour of the distortion screensavers? May be graphic drivers bug? Or could it be solved with some configuration changes in compiz and/or nvidia settings?

Thanks in advance.

Which desktop???

KDE, sorry. Thought it was clear when I said kscreensaver wasn’t working.

So why are you running compiz with KDE4? You know it is not needed for most effects.

Sorry for the delay. Family and work kept me out of the machine.
First, need to get something clear. After reading your post, i’ve been investigating about the “compiz” thing. I had it installed, (I removed it a few minutes ago), but had nothing to do with the actual problems I was talking about. I’m using a spanish translated desktop, and thought “composición activa” was a bad translation of “compiz is running”, which is not the case. Blame on me :-/
But this leads to a more serious problem, since it’s just KDE and nVidia drivers involved now.

What we’re talking is about the “Active Composition”, found in System Preferences -> Desktop -> Desktop Effects. Beeing active, consistently yields to the mentioned problems with some screensavers: blank screens or images appearing partially.

I really appreciate your interest in this matter, but I think it’s the kind of problem that should be analized by kde or nvidia developers…

Any idea so far?

xr ghg wrote:
> I really appreciate your interest in this matter, but I think it’s the
> kind of problem that should be analized by kde or nvidia developers…

almost no developers come here, ever…so if the purpose of your post
was to interact with them you need to join their mail list, see, or irc, see, or log to
bugzilla, see

however, i’ll tell you it is my experience that some of the screen
savers are the problem…i don’t know which ones, and i have the
feeling that the savers that are a problem on my machine might be
different than the ones on your machine…

i’d be willing to bet a cup of coffee that you have your screen saver
app set to “random” which exposes you machine to ALL the savers…so,
naturally you will eventually find those that kill…

i suggest you pick one at a time and use each for days…then move on
to another…eventually you will learn which are ok and which are not…

and, each which does not work needs to have a bug logged against it…

see, it is highly likely that there are many different devs
involved…maybe one for EACH saver: so a bug saying “kscreensavers
sometimes cause blah blah…” is gonna cause mostly nothing to happen…

or, you can take the easy way out, like i did: just select “blank
screen” instead of random and save those cycles…and, run something
like folding@home instead…

DenverD (Linux Counter 282315)
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

I know what you mean, but I woulldn’t say they’re bugs in the screensavers theirselves. First, because I’ve been using that same screensavers in previous systems without a glitch. Second, because when composition is disabled, xscreensavers works just fine, while beeing kde4 composition active make them fail randomly. This happens just with some of them, the ones that take a background image and manipulate it. It’s clearly something going wrong between kde composition and/or nvidia here.

That being true, there should be more people afected…

I’ll take a look into kde and nvidia forums about that.

Anyway, the problem with the Media Player Screensaver is SuSE specific, I think it worked before, so some system update may have broken it.

Same applies to the web collage one: seems it’s been removed from the bunch of screensavers, maybe due some discussion about the images it can download from the net… but still appears selectable in the screensavers dialog box.

You said you were using compiz??