Screensaver doesn't work

I’ve set the screensaver three times to turn on after 12 min. and if doesn’t open. Is there something else that needs to be done to get the screensavers to work? (using ver 11 KDE4)

Mine doesn’t either, and the Ctrl+Alt+L keyboard shortcut to lock the screen doesn’t work and I don’t see an option for it under Control Center > Keyboard Shortcuts.

I’m also unable to use the Graphics Card and Monitor control within Yast.

I bought up a similar issue in the RCs as well, and didn’t get any replies, so maybe it’s a low priority problem. Actually, I’m not having much luck with any of the issues I’ve found so far, unfortunately.

I noticed (with GNOME) that it opened about 5 minutes after I clicked it the first time. Now it opens as expected. Not sure if it was gathering information the first time and something was locked.

It appears that something is amiss with everything related to the control of video.

Screensavers can be previewed but do not launch.
Unable to lock screen
Unable to use the graphics card control in Yast.

I’ve reviewed the /etc/X11/xorg.conf and nothing appears to be incorrect, however I am unable to run “Yast2 X11” or to access the Graphics options under Yast.

I’m having the same problem with Gnome. I can’t lock the screen/screensaver doesn’t work (but graphics card and monitor does work for me).

I’ve found that executing gnome-screensaver in the run dialog (alt+f2) fixes the problem for me. Still annoying that this isn’t being launched by default though.

screensaver works here. you guys seem to have something broken

KDE4 on a PIV, Intel 915, ATI9250 (AGP) and I have the same issue.
Screen saver can be previewed but when it does kick in under normal circumstances it locks system up.

Have disabled for now (saves power anyway) but a fix would be nice…

I’m suspecting openGL issues, but haven’t looked further.

Same here - worked ok in SUSE 10.3, but in a fresh install of SUSE 11 I get a gray screen even on the preview. :frowning:

same with my machine. Prior to the upgrade from 10.3 lock mechanism and screensaver both worked fine, now I can’t lock the screen anymore. Screensavers can be previewed but do not lock the screen. I see this as not unimportant security feature. Video works fine, btw.

greetings, rws

I went back to KDE 3 until KDE 4.1 comes out and the screensavers are working. :slight_smile:

did a fresh install and now the screensaver/lock mechanism works fine.

greetings, rws

I earlier posted a note about the screen lock not working any longer as well, and have since discovered the screen lock appears to be part of the screen saver app (I rarely use the screen saver so I didn’t notice it wasn’t working until I started tinkering around).
Tried an uninstall & reinstall of the screen saver/lock app, no changes - still broken.
I am seriously not interested in wiping my system just to get the stupid saver/lock working.

Has this been reported as a bug yet? Looks like we have enough people having problems to officially call it that :frowning:

OK, found a bug about the screen saver not working under KDE on 11.0 - updated it stating that it doesn’t work under GNOME either, and that the lock function also doesn’t work.
Here’s hoping for a quick fix!

I found that gnome-screensaver was not loaded. I’m not sure what’s the proper way of getting it to load when the session starts, but here’s what I did to get it to work.
-go the Control Center
-under System, click on Sessions
-in the Startup Programs tab, click Add
-in Command enter /usr/bin/gnome-screensaver
-in name, enter whatever (e.g., GNOME screensaver)
-click OK and then Close
-logout and login again…now the “Lock Screen” button in the menu should work

Huh - yeah, adding it to the startup programs got it working at least from the menu for me too… didn’t realize it needed to be started as it’s own separate thing.
Now, if only I could get the ctrl-alt-L shortcut to work again… :confused:

My screen saver now seems to be working ok after KDE 4.1 was released and installed via the automatic updates in Yast. :):):slight_smile: