Screens go black after 10 minutes or so in openSUSE 11.2


Since openSUSE 11.2 I have had an issue which seems to be powersaving thing, but I haven’t got any powersaving settings enabled. I use gnome. Gnome-screensaver is disabled from gnome-screensaver-preferences, and also gnome-power-preferences are set to “Never”. And yet my screens are turning black every time I leave my keyboard for a moment.

How to prevent this? I don’t want my screens to powersave without my permission. I want them on all the time. Is there some new settings in openSUSE 11.2?



Just a guess here - possible DPMS issue? Can you disable in BIOS? Some screen savers can invoke this behaviour, so make sure this is disabled first. The DPMS option used to appear as an in xorg.conf (Monitor section), but in many cases this file is not required now.

The following command should tell you if DPMS is disabled or not

xset q|grep DPMS

If enabled, try disabling with

xset -dpms

Not sure if you need to be root for it to work. Check status again to confirm. Report back. :slight_smile:

BTW, other possible useful xset commands:
xset s off
xset s noblank

Same problem here Sir. I solved it in another distro, but I don’t remember…booting up another machine. Think I left a note.


Here is the output:

[21:29:10] rolle@peikko:~$ xset q|grep DPMS
DPMS (Energy Star):
  DPMS is Enabled
[21:39:34] rolle@peikko:~$ xset -dpms
[21:39:52] rolle@peikko:~$ xset s off
[21:40:00] rolle@peikko:~$ xset s noblank
[21:40:02] rolle@peikko:~$ 
[21:40:02] rolle@peikko:~$ xset q|grep DPMS
DPMS (Energy Star):
  DPMS is Disabled
[21:40:31] rolle@peikko:~$ 

So it was enabled. I will report back if I get black screens after I go away from keyboard.

That did the job Sir. I am greatful. Thank You!

Here as well. Thank you very very much deano_ferrari. This case is officially SOLVED. :slight_smile:

Thanks for update. One more thing though: This commands effects will not be persistent. When you boot up next, you will need to invoke the command again, so you could put the xset commands in a startup script.

I noticed this today. Thanks for the tip!