screenlocker quit working partially


I’ve been using Tumbleweed (KDE) for a few months now and so far it’s ok.
I have been doing a zypper dup for all udates and have only the packman repo added all else is factory or as original to the install.

With the last updates as of Jan 11 the screen locker quit working on cli, it still locks with control+alt+L and with the widgit.

I use command line due to locking with a script and doing other things at the same time.

I was using “qdbus-qt5 org.kde.screensaver /ScreenSaver Lock” whick locked the screen no problem.

Now when I run the above command in a terminal it returns “Service ‘org.kde.ScreenSaver’ does not exist.”

Since it does still work by using the widgit or control+alt+L keys it must have changed some directories or the command needed for cli.

Does anyone know what it may have changed to or what a new cli way that would work could be?


Try this instead:

qdbus-qt5 org.freedesktop.ScreenSaver /ScreenSaver Lock

This should work with GNOME too btw, and maybe other desktops (that conform to the standards…), also KDE4 already.

I gave that a try and the same comes back “Service ‘org.kde.ScreenSaver’ does not exist.”

I even tried both commands with the qt5 removed “qdbus org.freedesktop.ScreenSaver /ScreenSaver Lock” “qdbus org.kde.screensaver /ScreenSaver Lock”

It has me confused for sure considering I can lock the screen with the widgit just by a click and control+alt+L still works. It’s just the command line that is messed up or changed.

I use the command line in a script to pause music or even a movie when I run the script to lock.

Yes I have tried just the single commands ( original one I use and the one suggested ) in a terminal to see why the script stopped working partially and even using the terminal the screen don’t lock. Tried as user and su.

Screen doesn’t lock but the music or movie would pause and any network drives would unmount if mounted with the script.

Something with the big update that day changed and I seem to be looking at a forest and missing the tree.


I did a reboot and your suggestion does work. Beats me why a reboot helped but things sorted out. Rebooting is a last resort for me and I tend to forget to try it.

Thank you for the help :slight_smile:

where and how can I mark this as solved properly? I always feel I left things half done with no follow up for others.


Yes, strange.

But the error message in your previous post still talks about org.kde.ScreenSaver.
Maybe you started the wrong script, or didn’t update it correctly? :wink:

Thank you for the help :slight_smile:

You’re welcome.

PS: it should not matter whether you use qdbus (the Qt4 version) or qdbus-qt5. DBUS is independent of Qt…