Screen Tearing with Nvidia Drivers

Running LEAP 42.1 fully updated and have installed proprietary Nvidia drivers (I have a GTX 970).

When scrolling and watching videos through Chrome there is substantial screen tearing, it’s very noticeable.

I found this potential solution through searching online:

The fix it proposes seems to work but the permanent solution involves editing xorg.conf which I had thought was depreciated?

Not sure if this issue is particular to OpenSUSE or not? Anyone else experienced this or know of a solution?

what driver are you using G04 or G03, is that a desktop or a laptop as most laptops need bumblebee not the regular nvidia driver
I’ve never had tearing issues with my nvidia card and I’ve never installed or used chrome it could be a google issue
are the video’s you’re watching embedded in flash objects or html5 tags as chrome uses pepper-flash or a google moded version of ffmpeg for each respectfully and while you can enable/disable hardware acceleration in pepper-flash tweaking google’s ffmpeg is not as simple
I’d suggest you try chromium with chromium-ffmpeg from packman and see if the issue is still there
the info from the link you posted can be used on opensuse but the xorg.conf file has been depreciated and you will have to make a new one.

Thanks for the detailed reply.

I’m using the G04 driver, it’s a desktop. To be fair I should probably test it in Firefox or Chromium - it’s HTML5 regardless.

I’ll give your suggestions a shot after work and report back. Cheers.

Just to follow up, I generated an xorg.conf using nvidia x-server then just added in the line as per the link I included in my original post.

This fixes the screen tearing but I’d really like to know if this is a specific issue I’m having with OpenSUSE or if other users experience this. A quick Google search on nvidia screen tearing in Linux shows that it’s not an uncommon problem but it’s not entirely clear why it happens I guess.


I just installed OpenSuse Leap 42.1, Nvidia Drivers and I was getting this issue whenever using Google Chrome or watching a Video on Youtube. Your tip did the trick :). Thanks for sharing that link.

It seems to be problem of non KDE applications.
I tried Firefox, Gimp, LibreOffice. Tearing during opening and closing of windows.
I do not use proprietary nvidia driver.

What is set as the renderer? openGLX or xrender???

According KInfocenter:
OpenGL->Renderer: Mesa DRI Intel(R) Haswell Mobile

I also tried restart notebook.
So far I am without tearing again.

In Configure Desktop - Desktop Effects - Advanced - compositing what you got there???

Sorry, but I am not able response, because I have system in Slovak, so I do not know find value what you need.
But never mind.
System works correctly since yesterday’s restart.

Also disabling 3D effects (ALT+SHIFT+F12 in KDE4) make tearing go away in oS 13.2 here.

Tearing has appeared today again.
I use Bumblebee, so I checked packages related to it.

I found that packages
have not been updated since 25. 6. 2016.

There was problem with package vendor change. So automatic update did not work.
So I updated manually.

It seems that this helped.

I did a bit of testing with some other distros as well as DE’s and to be honest it seems like it’s linked to KDE - I did not see much, if any tearing with GNOME, Unity or Cinnamon. I did however see the same type of tearing in Manjaro KDE edition and the fix that I had posted earlier also worked there.

as you are using a hybrid system with bumblebee it’s most likely the intel part of the graphics system (you need to use optirun to use nvidia hardware)
plasma 5 has issues with intel’s sna acceleration the only workaround is using uxa, so try

kdesu kate /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"    Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"