Screen-tearing after latest updates in Tumbleweed KDE

Hello,
After the lates updates, I got huge screen-tearing.
I don’t understand why.
I don’t know how to find out what were the latest updates.
Now I got double options :

PS
if I select Wayland, it just boot into terminal.
I had to “startx” my way in

You didn’t write anything about where your TW lives. Please provide input/output using code tags (</> icon above input area) from running inxi -SGaz in Konsole.

sry,

$ inxi -SGaz 
System:
  Kernel: 6.5.3-1-default arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5.3-1-default
    root=UUID=12607de0-c8f5-4308-bf57-b3ea2dbf429a security=apparmor
    nosimplefb=1 mitigations=auto
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
    dm: SDDM Distro: openSUSE Tumbleweed 20230917
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports:
    active: HDMI-A-1 off: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:0a16
    class-ID: 0300
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
    620M/625M/630M/720M] vendor: Dell driver: nvidia v: 390.157
    alternate: nouveau,nvidia_drm non-free: series: 390.xx+
    status: legacy-active (EOL~late 2022) arch: Fermi code: GF1xx
    process: 40/28nm built: 2010-16 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 2 speed: 5 GT/s lanes: 8 bus-ID: 08:00.0 chip-ID: 10de:1140
    class-ID: 0302
  Device-3: Suyin Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1.5:5 chip-ID: 064e:9205
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
    compositor: kwin_x11 driver: X: loaded: modesetting unloaded: fbdev,vesa
    alternate: intel dri: crocus gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1280x720 s-dpi: 96 s-size: 337x190mm (13.27x7.48")
    s-diag: 387mm (15.23")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary model: Samsung
    serial: <filter> built: 2010 res: 1280x720 hz: 60 dpi: 203 gamma: 1.2
    size: 160x90mm (6.3x3.54") diag: 1021mm (40.2") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 note: disabled model: LG Display 0x0456 built: 2014
    res: 1280x720 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
  API: OpenGL v: N/A renderer: N/A direct-render: N/A

From what I read Wayland on Nividia is still “work in progress”

Now I got double options :

Yes, I also see the same five options under Tumbleweed.

That’s why I want to use X11 and I selected Plasma(X11)

And that is not what you get??

About screen-tearing: Try searching for “nvidia screen tearing linux”

Well I don’t want to use nvidia, I want to use the CPU’s video.
I’ll search

I think the easiest way to do that is to physically remove the card, any reason not to do that?

Ok … that’s not an option, I have a laptop.
Isn’t there any option in Tumbleweed to choose what video driver I want to use ??

Did you check the BIOS? What brand BIOS do you have?

According to inxi output, the i915 kernel driver loaded for the Intel iGPU, and the proprietary NVidia kernel driver loaded for the NVidia GPU. But, only the modesetting X display driver loaded, which supports AMD, Intel, NVidia and various other GPUs. To me this suggests a configuration problem, which is confirmed by the three N/As for API:. It takes special effort to make these Optimus hybrid graphics laptops behave properly. Do you even have suse-prime installed? Have you tried to use it? It should be able to give your Intel iGPU control.

When was this installation new? Did it ever work right? If yes, were NVidia’s own drivers already installed, or did you later add them?

it’s not from BIOS, prior the last update the OS worked well.

yes, this was a brand new install of Opensuse Tumbleweed.
As I said in the first post, everything worked ok before the updates.
I did not install anything nvidia-related on my own. Only in the updates I noticed that there were some nvidia updates…

I don’t know what that is.

I just want to use the Intel integrated graphics.
In my experience I get more stability.

Install suse-prime. Use it to specify use of Intel.

1 Like

Ok, I install it with zypper … how do I use it ?
I’m kinnda a newbie at this.

https://en.opensuse.org/SDB:NVIDIA_SUSE_Prime
But it will not work with wayland…

1 Like

happy happy joy !!!
So suse-prime was installed already, but I had to manually exec prime-select boot intel
Now is fine
Thank you all for the help !

2 Likes