Screen Size/Resolution in 11.3

Running new installation of 11.3 with KDE Desktop.
I have sorted out text appearance and size thanks to pwabrahams in another thread but I have a big problem with screen size/resolution.

In previous installation of 11.1 on the same machine I was able to change the resolution of the graphics in order to fit the windows on the screen more comfortably. I used to use something like 1240 x 1048 but in the System Settings > Computer Administration > Display the resolution is set at 832 x 624 and no higher resolutions are offered.

I cannot find out the details of the embedded graphics controller (10 year old Dell PE6300 server) but the system information report it as ATI Mach64 GI with swrast (No 3D acceleration) version 7.8.2. I have spent several hours reading the many pages on graphics in this forum and have concluded that I should probably be using a legacy driver but have no idea how to change the driver so again am seeking help. Of course if it were possible to increase the resolution to 1240 X 1048 without recourse to changing driver that might do it if I knew what setting to tweak.

If anybody can help here it would be much appreciated.

Hi please give output of:


In addition to providing the output of typing in a konsole (as recommended by ah7013):


here is some basic practical theory on openSUSE graphic card drivers that you might find educational/helpful :
openSUSE Graphic Card Practical Theory Guide for Users

and instructions on installing graphic drivers on openSUSE-11.3:
SDB:Configuring graphics cards - openSUSE

but before you go installing anything, I recommend you also open the file /var/log/Xorg.0.log and copy the contents and paste the contents to the webpage SUSE Paste and press create and post here the website/url address of that page, so our forum experts can look at the contents of that log file and provide you advice.

Hi and thanks for the quick reply. First xrandr gives:-
:~> xrandr
Screen 0: minimum 320 x 175, current 832 x 624, maximum 832 x 624
default connected 832x624+0+0 0mm x 0mm
832x624 75.0*
800x600 85.0 75.0 72.0 70.0 65.0 60.0 56.0
700x525 75.0 60.0
640x512 85.0 75.0 60.0
640x480 85.0 75.0 60.0 73.0
720x400 70.0 85.0
640x400 85.0
576x432 75.0
640x350 85.0
512x384 87.0 85.0 75.0 70.0 60.0
416x312 75.0
400x300 85.0 75.0 72.0 60.0 56.0
320x240 85.0 75.0 73.0 60.0
360x200 85.0
320x200 85.0
320x175 85.0

I am seeking the ability to run at 1280 x1024 .

I have spent many hours reading the background Theory Guide. Unfortunately I still do not know exactly which integrated graphics controller is built but have asked the question on the Dell server forum. Meanwhile here is the existing log file.

SUSE Paste

I suspect I need the legacy driver but if you have time to look at this I know it will mean more to you than me.

Further investigation tells me that I would be happier with 1024 x 768 which is what I now use on my OS/2 system with same monitor because this is easier to see. This may help.


You can find out what graphics controller you have like this:

/sbin/lspci | grep VGA

Hi and thanks for the suggestion. Tried it but where does the output go? Nothing appeared to happen when I ran it.
Getting late. Will try again tomorrow.
Time flies when you are having fun.

Cut and paste the line pertaining to your graphics card:

/sbin/lspci -nnk

If you’re in doubt, then post the entire output.

I quoted some lines from the Xorg.0.log file from the paste you provided :

#    57.604] (II) MACH64(0): VESA BIOS detected
#    57.604] (II) MACH64(0): VESA VBE Version 2.0
#    57.604] (II) MACH64(0): VESA VBE Total Mem: 2048 kB
#    57.604] (II) MACH64(0): VESA VBE OEM: ATI MACH64
#    57.604] (II) MACH64(0): VESA VBE OEM Software Rev: 1.0
#    57.604] (II) MACH64(0): VESA VBE OEM Vendor: ATI Technologies Inc.
#    57.604] (II) MACH64(0): VESA VBE OEM Product: MACH64GT
#    57.604] (II) MACH64(0): VESA VBE OEM Product Rev: 01.00
#    58.705] (II) MACH64(0): Manufacturer: IBM  Model: 1a4f  Serial#: 16843009
#    58.705] (II) MACH64(0): Year: 2004  Week: 35
#    58.705] (II) MACH64(0): EDID Version: 1.3
#    58.705] (II) MACH64(0): Analog Display Input,  Input Voltage Level: 0.700/0.700 V
#    58.705] (II) MACH64(0): Sync:  Separate  Composite  SyncOnGreen
#    58.706] (II) MACH64(0): Max Image Size [cm]: horiz.: 41  vert.: 30
#    58.710] (II) MACH64(0): EDID vendor "IBM", prod id 6735
#    58.710] (II) MACH64(0): Using EDID range info for horizontal sync
#    58.710] (II) MACH64(0): Using EDID range info for vertical refresh
#    58.707] (II) MACH64(0): 1280x1024@75Hz
#    58.709] (II) MACH64(0): EDID (in hex):
#    58.709] (II) MACH64(0):    00ffffffffffff00244d4f1a01010101
#    58.709] (II) MACH64(0):    230e01036e291eaceb9c68a0574a9b26
#    58.709] (II) MACH64(0):    12484ca44300d159c1598199e14f6159
#    58.709] (II) MACH64(0):    4559a94f3159a659403062b0324040c0
#    58.709] (II) MACH64(0):    130088261100001e000000ff0032342d
#    58.709] (II) MACH64(0):    44303635340a20202020000000fc0049
#    58.710] (II) MACH64(0):    424d20433232305020435254000000fd
#    58.710] (II) MACH64(0):    0032a01e8225000a2020202020200018
#    58.710] (II) MACH64(0): EDID vendor "IBM", prod id 6735
#    58.710] (II) MACH64(0): Using EDID range info for horizontal sync
#    58.710] (II) MACH64(0): Using EDID range info for vertical refresh
#    58.710] (II) MACH64(0): Printing DDC gathered Modelines:
#    58.714] (--) MACH64(0): ATI 3D Rage Pro graphics controller detected.
#    58.714] (--) MACH64(0): Chip type 4749 "GI", version 4, foundry UMC, class 0, revision 0x01.
#    58.714] (--) MACH64(0): PCI bus interface detected;  block I/O base is 0xEC00.
#    58.714] (--) MACH64(0): ATI Mach64 adapter detected
#    58.718] (WW) MACH64(0): Cannot shadow an accelerated frame buffer.
#    58.719] (II) MACH64(0): Default Monitor: Using hsync range of 30.00-130.00 kHz
#    58.719] (II) MACH64(0): Default Monitor: Using vrefresh range of 50.00-160.00 Hz

#    58.723] (II) MACH64(0): Not using driver mode "1280x1024" (insufficient memory for mode)
#    58.723] (II) MACH64(0): Not using driver mode "1024x768" (insufficient memory for mode)
#    58.723] (II) MACH64(0): Not using driver mode "1024x768" (insufficient memory for mode)
#    58.724] (WW) MACH64(0): Shrinking virtual size estimate from 2048x1536 to 832x624

From that one can see that your PC is using the Mach64 driver.

I don’t know anything about this driver. So I tried to learn some more. If I type:

rpm -ql xorg-x11-driver-video 

I can see a list of the files that come with that rpm (and hence see the kernel modules/drivers that are available), and I note:


Unfortunately I do not see any corresponding /usr/share/man/man4/mach64.4.gz file which would indicate the presence of a ‘help’ file … ie there is no help file for this driver called mach64.

Also, I note from the Xorg.0.log file that I quoted above that your monitor’s EDID is detected, which is good. The Mach64 hardware is detected, but the resolution you want is rejected due to the error code:

# 58.723] (II) MACH64(0): Not using driver mode "1280x1024" **(insufficient memory for mode)**
# 58.723] (II) MACH64(0): Not using driver mode "1024x768" **(insufficient memory for mode)**

… and with no ‘help’ for the mach64 I don’t see how to force the higher resolution using the mach64 driver.

However, I also noted this in the "rpm -ql xorg-x11-driver-video "


which tells me there is a help man file called ‘ati’

If you type:

man ati 

you will find a help file :slight_smile: for ati and it mentions it works with mach64.

       ati  is  an  Xorg wrapper driver for ATI video cards.  It autodetects whether your hardware has a Radeon, Rage
       128, or Mach64 or earlier class of chipset, and loads the radeon(4), r128(4), or mach64 driver as appropriate.

       The ati driver supports Radeon, Rage 128, and Mach64 and earlier chipsets by loading those drivers.  See those
       manpages for specific cards supported.

Now the information to speculate like I did above is mostly in the practical theory guide I quoted, but it requires experience in applying the theory, and I understand that is not so straight forward.

Hence I’m thinking (I’m guessing really) you could try the “ati” kernel module/driver ? Just a guess on my part thou, as I really do not know.

To do that, you should first confirm you have ‘mc’ (midnight commander) program installed. It will provide you a nice editor in a full screen text mode, which might come in handy if you get stuck in a text mode (in which case you type ‘mc’ and you get a self explanatory editor).

So, to try the ‘ati’ kernel module/driver, you could edit your openSUSE-11.3’s /etc/X11/xorg.conf.d/50-device.conf file, and change it to:

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  **Driver "ati"**

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"


Where you can see I proposed adding the driver “ati” line (in red in my example).

Reboot and test. If your PC fails to boot to a GUI, then login to the full screen text mode, and run the program ‘mc’ and edit the file 50-device.conf to remove that line you added.

Now its also possible you can boot to a GUI with the “ati” driver, but the resolution is still not correct. In which case, you will need to again provide the information you did already, ie output of “xrandr” and the paste directory where you again pasted the contents of the “/var/log/Xorg.0.log” file.

And of course, anyone with experience with the ‘mach64’ is welcome to chime in and provide better advice than my 'guess.

Good luck.

Edit : ** re-reading the ‘man ati’ I’m thinking that may also not help, and it may simply result again in the ‘mach64’ driver being loaded with same problem. … Are you certain your graphic card has sufficient memory for what you have in mind ? *

We need the output of the command noted from deano_ferrai, as it is possible the “r128” driver is more appropriate. ie without more information posts like my above are pure speculation and possibly not very helpful.

While we’re waiting for more info, this reference is good for Mach64 chipsets, including the ATI Rage Pro (which I suspect the OP has):


We need the output of the command noted from deano_ferrai, as it is possible the “r128” driver is more appropriate. ie without more information posts like my above are pure speculation and possibly not very helpful.[/QUOTE]

My guess is we will discover your graphic device to be the 1002:4749 based on this from your /var/log/Xorg.0.log file:

    57.203] (--) PCI:*(0:0:4:0) **1002:4749**:1028:007f ATI Technologies Inc 3D Rage Pro rev 92, Mem @ 0xfd000000/16777216, 0xfe900000/4096, I/O @ 0x0000ec00/256, BIOS @ 0x????????/131072

… and if I google search for “1002:4749 PCID” I find this Link PCI Devices which suggests your card is a 3D Rage Pro consistent with what else the /var/log/Xorg.0.log file says.

So I am coming back to ‘full circle’ and thinking that “mach64” may be the correct driver after all and wondering about the message:

 (II) MACH64(0): Not using driver mode "1280x1024" (insufficient memory for mode) 

I assume the memory on the card is properly ‘seated’ and did not work itself loose ?

I tried searching on this and noted a thread:
HOWTO: enable 3d acceleration w/ Rage Mobility (mach64) - Page 22 - Ubuntu Forums

Where a user edited an xorg.conf file to force a resolution.

However this is beyond my expertise, so I think I need to back out of this thread and let other’s who know more than I provide more useful suggestions than what I can provide.

deano_ferrai, that reads to be an excellent link !

In particular this quote:

  • AgpSize: sets the AGP aperture in MB - The video card can access this amount of system memory using AGP and shared access in order to expand its memory capacity - enlarging this allows more textures to be stored here.
  • BufferSize: sets DMA buffer memory size in MB. Default is 2 MB. May be 1 or 2.

The AgpSize option changes the amount of system memory used for the AGP aperture and is not limited by the size of the card’s on-board video memory. This memory is used for the DMA buffers BufferSize option), and the remainder is allocated for AGP textures. Of course, the AgpMode/AgpSize options are ignored for PCI cards or if ForcePCIMode is enabled on an AGP card. However, the BufferSize option can be used to change the size of the DMA buffers in system memory for both PCI and AGP cards (but it’s not recommended to reduce the buffer size unless you are short on system RAM).

Hi and many many thanks to oldcpu and deano and andrew for the time taken on my behalf.
There was one question which I need a prompt on: Where is the output when I run

/sbin/lspci | grep VGA?

Also will there be a similar problem when I run /sbin/lspci -nnk?

The machine in question is off and I am about to leave for town. Will return this evening to continue working on the above.

There should be no problem running:

/sbin/lspci -nnk 

when you ran “/sbin/lspci | grep VGA” that command took the output of the /sbin/lspci command and piped it through the filter grep such that only lines with the word(s) VGA should appear. For some reason that did not appear. Either VGA was not contained, or there was a syntax error. Note Linux is case senstive, and “vga” is NOT the same as “VGA”.

But the command

/sbin/lspci -nnk 

will work fine.

No worries. When ever you get around to this.

Hi, on my laptop so can’t paste output and forgotten details but graphics card was identified. The memory/performance is limited no doubt because of the age of the machine and that it was built as a server so high res graphics were not needed.
In fact I would be happy with 1024 x 768 with 64 kb colour depth and I believe that is how I ran it before. I shall continue reading the links given and see if it is possible to tweak colour depth (hope that is the correct term).

If all else fails I might pick up a card on ebay but will need to check what slots are available. Probably only PCI.
Thanks again for the help. Will post output when I am back at other machine.

Hi, I have now found the Dell Service Manual of my machine. This confirms

‡ A VGA-compatible video subsystem with an ATI 3D RAGE PRO SVGA video controller. This video subsystem contains 2 MB of SGRAM video memory (nonupgradeable).

So that confirms your conclusions regarding the integrated video controller. If I can solve my problem by reducing what I have referred to as colour depth (I mean the number of colour bits) then I shall be OK. I do not need 3D so will not be trying the above suggested fix which is well beyond my capability.

If I have to find a video card on ebay I would appreciate some help. There are seven PCI connectors, four 64-bit and three 32-bit. The three normal 32 bit PCI slots are all occupied. There are however 4 empty 64 bit slots but they look unfamiliar and wonder if there was ever a 64 bit PCI video card made. I shall do more research myself but if you have any info please advise.

Thanks. But it still may be helpful for you to run the command:

/sbin/lspci -nnk 

It will confirm my speculation that 1002:4749 is the vendor-id:device-id. I have found when trying to support users that often a search on the vendor-id:device-id will take me to web pages where others have addressed a similar problem, and hence once can get hints as to the solution. I’ve been trying to search on 1002:4749, but maybe I’ve been using a wrong number ? So when you get the chance, please run that command.

Is the graphics integrated on the motherboard? I assume its not an AGP card nor PCI card?

In such an old PC, a risk in purchasing any graphic card is the PC’s power supply my have degraded so much, that the power is not there to properly run a different graphic card. So caution is needed from that perspective.

To check the ideas in the archlinux mach64 wiki page tend more to be a trial and error ? For example, you could try variations of this in your /etc/X11/xorg.conf.d/50-device.conf file:

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  Driver  "mach64"
  Card    "ATI Rage Pro - Mach64"
  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

  ## Default DMAmode is asyn. Could try sync or mmio
  Option "DMAMode" "asynch"

  ## boolean, disables AGP apeture. Set True for PCI card
  Option "ForcePCIMode" "true"

  ## AgpMode (AGP 1x or 2x) : 1 or 2. Default agparts mode
  Option "AgpMode" "1"

  ## Sets AGP apeture in MB. Also try 16 and 32 if 64 fails.
  Option "AgpSize" "64"

  ## sets DMA buffer memory size in MB. Default 2
  Option "BufferSize" "1"

  ## see the archwiki. If true fails, try false.
  Option "LocalTextures" "true"


and play with various combinations of the above. Double check my syntax also, because I may have typed it wrong. Keep checking the /var/log/Xorg.0.log file for hints as to why a specific effort may have failed.

What I was trying to do with the above was get rid of the ‘insufficient memory’ error that you observed in the Xorg.0.log file. Once you succeed with that, then maybe an edit to another file (possible 50-monitor.conf) can increase the resolution ! :slight_smile:

Now like you, I am not so good at this, and others can likely provide better suggestions, but if it were me, I would start experimenting with that. Of course BEFORE any /etc/X11/xorg.conf.d/50-device.conf edit, one should install the program ‘mc’ (midnight commander) which provides an easy to follow capability to edit the file 50-device.conf in text mode. That way if you find yourself stranded in a text mode after an edit that did not work, you can simply revert the change.

Do NOT put any backup files in /etc/X11/xorg.conf.d/ directory. Backup files should go elsewhere.

Hi, I’m back to trying to sort out my screen resolution and trying to pick up where I left off.
I really didn’t want to get too much out of my depth editing the conf file so I though I would do a re-installation of 11.2 keeping the existing /home partition intact. My intention being to get back to the old X Window system which allowed me to edit the parameters I needed.

Well the installation went fine but after I had allowed all the security updates and patches I was back to KDE 4.3.5 release 0. The good news is that my fonts have remained clear and as previously set when 11.3 was installed but there is no means to adjust anything like I hoped. My /home directory has .kde and .kde4 but /usr/sbin/lspci -nnk gives nothing and when I look in /usr/sbin there is no lspci present!!!

In other systems there has been a trade off between resolution and number of colour bits and I would be happy to work with fewer colour bits if I could get the resolution I seek. Meanwhile why is thre no lspci ?

Comments/help would once more be appreciated.

Tried to edit the above and ran out of time. lspci is in /sbin not /usr/sbin. Here is the output requested:-

/sbin/lspci -nnk
00:02.0 ISA bridge [0601]: Intel Corporation 82371AB/EB/MB PIIX4 ISA [8086:7110] (rev 02)
00:02.1 IDE interface [0101]: Intel Corporation 82371AB/EB/MB PIIX4 IDE [8086:7111] (rev 01)
Kernel driver in use: ata_piix
00:02.2 USB Controller [0c03]: Intel Corporation 82371AB/EB/MB PIIX4 USB [8086:7112] (rev 01)
Kernel driver in use: uhci_hcd
00:02.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 02)
00:04.0 VGA compatible controller [0300]: ATI Technologies Inc 3D Rage Pro [1002:4749] (rev 5c)
Subsystem: Dell Device [1028:007f]
00:06.0 Ethernet controller [0200]: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 [8086:1229] (rev 05)
Subsystem: Intel Corporation 82558B PRO/100+ PCI (TP) [8086:0009]
Kernel driver in use: e100
00:08.0 PCI bridge [0604]: Intel Corporation 80960RP (i960RP) Microprocessor/Bridge [8086:0960] (rev 03)
00:08.1 SCSI storage controller [0100]: Intel Corporation 80960RP (i960RP) Microprocessor [8086:1960] (rev 03)
Subsystem: Dell PowerEdge Expandable RAID Controller 2/SC [1028:1111]
Kernel driver in use: megaraid_legacy
00:0a.0 Multimedia audio controller [0401]: Creative Labs SB Live! EMU10k1 [1102:0002] (rev 08)
Subsystem: Creative Labs Device [1102:8062]
Kernel driver in use: EMU10K1_Audigy
00:0a.1 Input device controller [0980]: Creative Labs SB Live! Game Port [1102:7002] (rev 08)
Subsystem: Creative Labs Gameport Joystick [1102:0020]
Kernel driver in use: Emu10k1_gameport
00:10.0 Host bridge [0600]: Intel Corporation 450NX - 82451NX Memory & I/O Controller [8086:84ca] (rev 03)
00:12.0 Host bridge [0600]: Intel Corporation 450NX - 82454NX/84460GX PCI Expander Bridge [8086:84cb] (rev 04)
Subsystem: Intel Corporation 450NX - 82454NX/84460GX PCI Expander Bridge [8086:84cb]
00:13.0 Host bridge [0600]: Intel Corporation 450NX - 82454NX/84460GX PCI Expander Bridge [8086:84cb] (rev 04)
Subsystem: Intel Corporation 450NX - 82454NX/84460GX PCI Expander Bridge [8086:84cb]
00:14.0 Host bridge [0600]: Intel Corporation 450NX - 82454NX/84460GX PCI Expander Bridge [8086:84cb] (rev 04)
Subsystem: Intel Corporation 450NX - 82454NX/84460GX PCI Expander Bridge [8086:84cb]
02:08.0 SCSI storage controller [0100]: Adaptec AIC-7860 [9004:6078] (rev 03)
Subsystem: Adaptec Device [9004:7860]
Kernel driver in use: aic7xxx

This confirms the integrated graphics controller to be the ATI Technologies Inc 3D Rage Pro [1002:4749] (rev 5c) which you advised earlier.


Hi all,
I think I have cracked it. Forgotten by me there is a tool I have just re-discovered in 11.2 with kde 4.3.5 Applications>System>Configuration>Configure X 11 System which does allow me to change resolution and this has allowed me to select 1024 x 768 with 16 bit colours and this appears to be working well. I now have all I need to get on with work.

What is the easiest way to stop and start X 11 System. At present I am restarting and this takes ages.

I shall try 11.3 later when I have time.
Thanks again for all the help.