Screen size in openSUSE 13.2 in VirtualBox 5.0.26

After a system update the virtual screen of my openSUSE is not getting automatically adjusted. That is, the “Auto-resize Guest Display” is grey.

I have tried to install virtualBox addition using zipper:

$ sudo zipper in virtualbox-guest-kmp-default virtualbox-guest-tools virtualbox-guest-x11

And did not corrected it.

I have also tried to install the addition using the virtual CD and it did not correct it either.

I would appreciate any help.

This has been reported, and it’s my impression this problem will not be resolved… possibly because 13.2 is approaching EOL (although still many months away as of today).

For awhile, I used these approaches…

  • Installed arandr and then manually re-sized the display.
  • Rebooted the vm, with the window sized to whatever I want (eg full screen)

I <didn’t> try installing a 4.x kernel which would have resolved the problem.

In the end, I just decided to upgrade to LEAP, as I mentioned 13.2 has less than 6 mths to go until EOL.


Thats very sad!! Unfortunately upgrading to LEAP is not an option to me. Do you mind explaining how did you use the arandr?


I managed doing thanks for your tip. For those with the same problem It follows a solution. I edited the file /etc/X11/xorg.conf.d/50-device.conf adding the following:

Section "Device"
 Identifier "Default.Device"
 Driver "vesa"

Just to be clear here:
on 13.2 you are likely using kernel-desktop, so installing virtualbox-guest-kmp-default doesn’t make sense.
You need virtualbox-guest-kmp-desktop.

Despite what tsu2 wrote, I don’t think there’s a problem with the guest additions in 13.2 (and no, it is not considered EOL yet by far).
That’s only a problem in Tumbleweed currently, because of the newer kernel and Xorg (a fix is on the way though AIUI).

There is one “problem” though: the installation location of the guest kernel modules have been moved from /lib/modules/xxx/updates to /lib/modules/xxx/misc to be more aligned with the upstream guest additions.
Unfortunately, /lib/modules/xxx/updates is searched before misc, so if you still have an older version installed (because of the kernel multiversion feature), it won’t work because the kernel will load the older version.

My recommendation:
uninstall virtualbox-guest-kmp-desktop in the guest completely, and reinstall the latest version:

sudo rpm -e --nodeps --allmatches virtualbox-guest-kmp-desktop
sudo zypper in virtualbox-guest-kmp-desktop

That should fix it.
See also

Yeah, It solved!!
Thank you!