Screen resulation problem in 11.4

I have installed opensuse 11.4 couple of days ago. Installation went smoothly. Everything is working just fine except the screen resulation. My Monitor supports up to 1366768. The Display Settings in 11.4 gives option of 1366768, But whenever I maximize any window (say firefox, opera etc) I can not see the close button & scroll-bar.

Here is my xorg file of monitor.

Section "Monitor"
  Identifier "Default Monitor"

  ## If your monitor doesn't support DDC you may override the
  ## defaults here
  #HorizSync 28-85
  #VertRefresh 50-100

  ## Add your mode lines here, use e.g the cvt tool


So What I need to do to fix this resulation problem?

Thanks in advance

For people to be able to help you mate you will probably need to give a bit more info

What graphics card you have and which driver you’re using would be a good place to start

I am using Ati radeon X200 with opensource driver (radeon) (works out of the box, did not have to do anything)

Please post the result (using CODE tags) of running the following command in a terminal (as normal user):


In your monitor conf you have this comment

Add your mode lines here, use e.g the cvt tool

It might help if you put your monitor’s modeline for the desired resolution in there, to get the modeline you type ‘cvt 1366 768’ in konsole (terminal if you’re using gnome), like this:

ecky@machine:~> cvt 1366 768

1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz

Modeline “1368x768_60.00” 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

The part you put in the monitor conf under the ##Add your mode lines here comment is this bit:

Modeline “1368x768_60.00” 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

Don’t just paste the line I’ve put here though, that’s the information from my monitor, yours is going to be different, so use the cvt 1355 768 command as I described above

Save the changes and reboot

In case you aren’t sure, to run xrandr as consused asked you to, just type xrandr in konsole or terminal

Here is the output of xrandr.

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 4096 x 4096
VGA-0 connected 1366x768+0+0 (normal left inverted right x axis y axis) 410mm x 230mm
   1366x768       59.8*+
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
S-video disconnected (normal left inverted right x axis y axis)

Is this a fresh install, or an upgrade from 11.3? I’m wondering of your ~/.kde4/share/config directory has some old config files in it, causing this strange window sizing?

As you are losing a few mm on the right side of your full screen, does 410mm x 230mm exactly match the physical display (screen) dimensions of your monitor?

@deano_ferrari, it’s a fresh install.

I don’t know why this is happening? In the cover 18.5 inch (47cm) is written…

I guess that isn’t the width of your screen! More likely to be the screen diagonal from corner to opposite corner, i.e. longer than the width or height. If you have a ruler, you can measure the width of the displayable area (not the casing) by hand as accurately as possible. Also measure the displayable height. Try and locate a published specification for your monitor.

BTW what is the brand/make and model/type of your monitor?

Did you configure monitor as suggested by @Ecky in post #5? You could also try that.

There could be some issue with the graphic driver. Check it once

It is Samsung syncmaster B1930.

BTW My x-server has stopped working (after sudden electricity-loss). So i can’t boot in a graphical mode (only CLI). :frowning: However i have tried startx command & see some error. I will open a different topic on that problem. :slight_smile:

OK, searching google, I keep seeing the native resolution quoted as 1360x768 for that display, and not 1366x768 as per xrandr’s report. That could have something to do with your display problem. By default, the system (xorg-xserver) is delivering 1366 pixels per width to a screen only capable of showing 1360 pixels per width.

Looks like you will need to configure a custom modeline like @Ecky suggested, assuming the graphic card/driver can handle the modesetting.

hasan, tell us what the error says when you run startx, look out especially for something saying:

line [somenumber] [some file called something like /etc/X11/xorg.conf.d/50-somefile.conf]

an example being: line 10 in /etc/X11/xorg.conf.d/50-monitor.conf

it’s often an error in one of the files in /etc/X11 causing startx to fail, and if that is the case probably not too difficult to fix

@Ecky Problem in graphical log in

Thanks to Ecky. Problem solved. use cvt 1360 768 in konsole.