Screen resolution


I have a problem with my screen.
I installed openSUSE 11.1 with VESA, because with the normal resolution, the screen went black.

The first time I the resolution was 800x600.
I set the resolution with sax 2 on 1280x1024 and I had to set a monitor, because nothing happened, if I don’t.
(It wasn’t the monitor I have, because there is no one in the list, which is mine; I have a LG Flatron L1715S)

Now I want to set the resolution a bit down (1024x768), but the screen goes black, if I do that.
Then I have to kill the computer and restart, then it works again (with the 1280x1024 resolution).

The same thing, is when openSUSE starts.
If it is the standart resolution, it shows me the text, but not the openSUSE picture.
If I set the resolution at the beginning of 1028x1024 (vga=0x324), the monitor writes, he is in sleeping mode and starts at the login again.

edit: I have a ATI Radeon X300 and with XP it worked without any problems

push no one who has an idea?

Why use anything but the displays native resolution? You’ll end
up with an interpolated resolution, and, even worse, they aren’t
the same aspect ratio, 5:4 native, 4:3 1024x768. Better use the
tools in Gnome or KDE to adjust font sizes, if that’s the issue.

I did, Sax 2 is a tool like that, but if I change the resolution, the screen goes black.

Yes, sax is a tool for that, but what I suggested was to rather
change font sizes, if you find them too small. In Gnome you do
that in the Control Center>Look and feel>Apperance>fonts. I’m
sure there’s something similar in KDE if that’s your desk top.
If you instead change the resolution to get better readability
you’ll loose the direct mapping beetwen what you output and the
displays fysical size, and I for sure don’t like the view that
method produces.

I think it is more the physical size, than the output.
Yes, there is a similar thing like in GNOME, but if I change the size, the monitor goes to sleeping mode and only a restart helps

Have you tried the horizontal sync parameter? It may be a refresh issue, no?

Do a sax2 --help or man to see how to use the command

sax2 -r 0:1024x768@65

That’s just an example and probably not right for you

Good Luck!

thank you, now it works