Screen Resolution on PowerBook G4 PPC using OSS 11 PPC.

I just installed OSS 11 PPC on a PowerBook G4 PPC, the screen resolution I get is 800x600, this is a 15" screen, Is there a way to get a deeper resolution than this?
I am a newbie with OSS, so please bear with me.



In openSUSE, we generally tackle that sort of issues by going to YaST > Hardware > Graphic Card and Screen, or alternatively, by running

sax2 -r

in a virtual console.

You mentioned you’re a bit of a noob…
so I don’t know how much you’ve already
figured out…I will explain this in LAYMAN’S TERMS…anyone else that reads this w/
a little experience may have differing opinions
or just a better way of doing things…

Basically, Apple Powerbooks typically
need a little hand-holding in the
video department…

Here is what I would do…

Go to the Install Software Icon in
the applications or Yast menu…
under Available applications, scroll
down to nano, install nano, trust me
it will help over vi…

Open up the Terminal (In Applications,
probably system or utilities)

Type in


to go into
root mode…you’ll need your root password


cp /etc/X11/xorg.conf /etc/X11/backup.xorg.conf

This will make a backup of your current
crappy configuration in case we need it…


sax2 -r

Assuming that access to your display is
granted (it needs to be, you’ll see it on the screen)
A window will eventually pop up showing
you your graphics card and monitor properties…
make sure you are using the video card
settings for your card (If it’s an ATI card
using some default driver, that could be
the problem right there…)

This is the most basic option…if after this
step a logout or ctrl+alt+backspace or a
reboot doesn’t fix the problem, you can go to this thread…

fixing video resolution on PowerBook G4 (openSUSE 11) - openSUSE Forums

and copy the xorg.conf at the bottom post
(literally just highlight and ctrl+c the text
in code tags) and go back to the terminal
and do a


again, and a

sudo nano /etc/X11/xorg.conf

Delete all lines of text, I think that’s a ctrl+K in nano

and use Shift+Ctrl+V to paste this code…

Ctrl+X and save as the same name that’s already
in there, “xorg.conf”

Now do a reboot, or a Ctrl+Alt+Backspace…

I really hope this helps, when I was on Ubuntu,
I actually saved an xorg.conf that worked for
my Powerbook on a thumb drive, just because
it never worked right, and that was the easiest
way to do it…I suggest that after you get it fixed
you do the same…

Good Luck…hope this isn’t overkill