Screen resolution not retained when shut down

In my new installation of SUSE 11.2 with KDE, the screen resolution is not being retained when the system is shut down and then powered up again. I have a Viewsonic GT775 and I get a badly distorted desktop when the system starts up as 1280x1024 80Hz. If I go to System Settings and change the resolution to 1280x1024 75Hz, the desktop display locks in beautifully. If I shut down and start up again, the display is back to 80Hz and distorted.
I found that the correct setting is kept if I suspend to disk and then power up again, the display is perfect and 75Hz, but not with a full shut down.
I am puzzled that the Display settings seem to have been removed from YAST. I am using configure desktop from the KDE start button.
Thanks for any help/suggestions you can offer!

Go to the menu and in the search field type: sax
click the app icon and run the config from there, test and save
logout and back in

Ah yes, I had tried that.
SaX2 comes up. It comes up set for 1280x1024 16.7 mil colors (no refresh rate). I push test and the test screen is 1600x1200 75KHz 60Hz and the position and size buttons don’t do anything. What am I doing wrong?

Further on SaX2: I was just in there experimenting with other screen sizes and sometimes SaX2 does not return me to the desktop, I am left with a black screen even after the 30 sec timeout. The Cntl-Alt-backspace beeps the speaker, but nothing else happens. I have to forcbably shut down the machine, restart, reset my refresh rate to 75 Hz (oh yes, and my mouse stops working at that point) so I have to use the keyboard to suspend the system to disk, restart and only then is the system usable again.

When I was able to try different sizes in SaX2, the test screen was always 1600x1280, not the size that I picked.

Have you a video driver installed?
ATI - openSUSE

I am using a Compaq EVO D515 with a built in graphics chip, an 845 I think. YAST seems to know about it (has it in the hardware list.

Now it seems to be “broken”.
If I boot normal SUSE, it comes up black screen.
I can only boot up in Safe mode. The screen is 1275x1024, what I want, but I can’t seem to Suspend to Disk in Safe mode? I can only shut down and then it comes up black screen, except if I start Safe mode.
Also, I got a perfect 1024x768 test screen in SaX2 (from Safe mode), I exited SaX2 and rebooted and now I have a black screen, except for safe mode start.

You could try removing /etc/X11/xorg.conf

console login, as user then become su and do

mv /etc/X11/xorg.conf xorg.conf.bak


Thank you. I did that.
After reboot, I was able to start in normal mode but again the screen was distorted (looked like 1600x1200).
I again tried SaX2 and was able to do several iterations, 1280x1024 and 1024x768 but in all cases the refresh rate was too high: 90 Hz, 80 Hz and I cannot control this. Reminds me of Windows NT issues I used to have many years ago.
I tried varying the number of colors displayed and made some differences, but never a stable locked in full screen display. Finally after the fifth try, SaX2 didn’t come back and I was left on a black screen requiring forced shut down. Rebooted in Safe mode and I now have a stable 1280x1024 screen to write you this but I think that if I close the system, I will not have a stable screen on reboot, unless Safe mode again.
Frustrating. Any other ideas?

Open a terminal and do

/sbin/lspci -nnk

Look for the Video chip part and post it here

00:02.0 VGA compatible controller [0300]: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562] (rev 01)

I know users have experienced some trouble with this Intel chip.

Try running sax2 from level 3

At the login - Login as user then switch to su and do

sax2 -r

If that doesn’t work
Boot level 3 again and do this instead

sax2 -r -m 0=intel

Another option

sax -r -m 0=vesa

FYI; Those are zero=
as in 0=vesa

Will do. Couple questions:

On the boot screen, mine has an option showing of:
Is that significant? Do I put the “3” after the existing option (with one space), or should I delete the existing?
I guessed and added the 3 after a space. I’m looking over at the machine now and I see that it has come to a stop at level 3. I will follow the rest of your instructions now.

The second question, is the first two suggestions you have typed SAX2 but the third, only sax. Is that intentional?

Here’s my report:

Both of the first two suggestions, with or without vga=0x31a: the SaX says it is going to start, the screen goes black and then it goes OFF.

With the third suggestion, (0=vesa), Sax starts and offers a 1024x768 16 bit screen as a “suggestion” but it is badly distorted (too narrow and too high and bowed).

I as it to let me try another and I get the SaX selector screen, I tried 1280x1024 16.7 mil and on the next try 1024x768 16.7 mil and in BOTH cases, the screen goes black but the monitor does not turn off. I needed to do a forced shutdown and reboot from both.

No joy yet.

Should I think about using a different graphics card? I have an nvidia that I could use, bypassing the onboard Intel i845?

If you have an nvidia - use it!!

first do this
level 3 boot
login as user become su and do

mv /etc/X11/xorg.conf xorg.conf.old

shutdown and put in the nvidia card
boot up (Check your BIOS that you don’t need to disable the on-board chip or select PCI as video option)

See how you get on

I’ve added an nvidia card to the machine as you detailled.
I have output from the nvidia and no output from the mainboard.
There is no disable in the BIOS for the onboard graphics, it seems to auto detect the added card and switch to that.

Initially it comes up as 1600x1200 (distorted display). Using Sax2, I try to set 1280x1024. Here’s the funny part: Sax2 was already set to 1280x1024 and it shows the graphics card as INTEL, not nvidia?!

I’m not having to use Safe mode to start and see my output, but when I log off and on, it comes back as 1600x1200. I have to switch to 1280x1024 using “Configure Desktop” and then it does not remember.

I’ll do it again now to check…

I haven’t specifically loaded nvidia software, but it seems to me that the problem is with SaX2.

Or is it possible that my Viewsonic monitor is the problem, or rather, what it think the GT775 is capable of?

Another curiosity that may be relevant, in YAST where I can list my hardware, it show the GT775 THREE TIMES in the list. Why is that?

Please see this page for help. Intel Linux Graphics: Documentation
This seems to be the drivers; Intel Linux Graphics: 2009Q3

Thank you Jonathan_R. I looked at both of the links but I am probably out of my depth with these references. There is a driver from Intel that I should download and install? On other advice from caf4926, I am now trying to use an nvidia Geforce 6200 and experiencing similar problems and not using the Intel graphics chip on the motherboard, so would I still need to use the Intel driver?

For nvidia 6 version and newer click this
let it run
then reboot