Screen resolution is very low on and after boot

After recent kernel upgrades after 4.20.x strange thing began to happen. Screen resolution is very low: on boot, on SDDM screen, then in KDE after login. Max and only available resolution is 1280x1024 while I have Full HD 1920x1080 screen. Deinstalled nvidia driver, installed nouveau however it helped only till 4.20.6 kernel upgrade, now same problem with nouveau driver. What is the problem and how to solve this?!

Created bugreport: https://bugzilla.opensuse.org/show_bug.cgi?id=1124625

First provide output from

inxi -GxxSM

run in an xterm or Konsole. Then, use the susepaste command

susepaste -n akontsevich  /var/log/Xorg.0.log

and paste here the URL that results. You might have to install inxi first:

sudo zypper in inxi
> inxi -GxxSM
System:    Host: localhost.localdomain Kernel: 4.20.6-1-default x86_64 bits: 64 compiler: gcc v: 8.2.1
           Desktop: KDE Plasma 5.14.5 tk: Qt 5.12.0 wm: kwin_x11 dm: SDDM Distro: openSUSE Tumbleweed 20190205
Machine:   Type: Desktop System: Gigabyte product: N/A v: N/A serial: <root required> Chassis: type: 3 serial: <root required>
           Mobo: Gigabyte model: 970A-DS3P v: x.x serial: <root required> BIOS: American Megatrends v: FD date: 02/26/2016
Graphics:  Device-1: NVIDIA GF108 [GeForce GT 730] vendor: Gigabyte driver: nvidia v: 390.87 bus ID: 01:00.0
           chip ID: 10de:0f02
           Display: x11 server: X.Org 1.20.3 driver: nouveau unloaded: fbdev,modesetting,vesa alternate: nv,nvidia
           compositor: kwin_x11 resolution: 1280x800~76Hz
           OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.3.2 compat-v: 3.1 direct render: Yes
> susepaste -n akontsevich  /var/log/Xorg.0.log

Pasted as:
SUSE Paste
SUSE Paste
Link is also in your clipboard.

At the first update of the Kernel 4.20 the Driver Nvidia was not synchronized with the Kernel, and it did not work … it was enough to start the previous Kernel, but the synchronization happened after many days, but in the end it worked perfectly, try again to install the Nvidia Drivers and give a zypper dup

If it was not synchronized - then it is a zypper dup fundamental problem. Why it worked with nouveau and does not work now?! They can’t uninstall nvidia drivers cleanly?

This helped, thanks! Strange it did not work previously as I tried to install nvidia-G05 (have G04 currently) and it had to be synchronized with current kernel after installation - so strange.

P.S. May be can tell as well why I have grey Plymouth screen on boot with either driver? :wink:

Plymouth should not be installed when NVidia’s proprietary drivers are installed.
https://bugzilla.opensuse.org/show_bug.cgi?id=1047225
https://bugzilla.opensuse.org/show_bug.cgi?id=1053811
https://bugzilla.opensuse.org/show_bug.cgi?id=1090451#c6

Ha, with PLymouth v0.9.2 works fine even if plymouth in the list of omitted: https://bugzilla.opensuse.org/show_bug.cgi?id=1090451#c11

But I uninstalled Plymout directly, the boot of my computer takes about 8 seconds, and even when it worked with the Nouveau Drivers I saw it only an instant;)

I like rotating infinity sign even for few moments :wink: