Screen resolution beyond physical size of monitor (TV), need xorg.conf settings

Hello everyone.

I’ve installed openSUSE 12.1 on a computer which uses a TV as monitor (Toshiba 32HL833), connected through HDMI. Everything is fine, except that the screen resolution boundaries go beyond the physical size of the screen, regardless of whether I set the resolution at 1920x1080 or 1280x720 (these are the only available options in the GUI System Settings - Display and Monitor). At the larger resolution, I suppose about 30 pixels are not visible on each side of the screen. The taskbar was visible like 3 pixels above the lower visibility boundary, so I have temporarily made it larger so that I can at least use the computer… but it really sucks having to grope in the blind for the “Launch Application” button, having to blindly drag down newly opened windows, and not being able to use Alt+F2 because the dialogue opens “above the screen” so to say (I know about the ‘kdesu’ command, but this doesn’t detract from the fact that not seeing the edges of your screen is not fun at all).

Relative noob here, but done a fair amount of searching around the forums (and reinstalled my system a couple of times). My xrandr can be viewed here - SUSE Paste - and I basically see that I need to crank down the “885mm x 498mm” to lower values. In the forum posts that I have searched here on the forums, I found an example:

Section "Monitor"
#DisplaySize 310 230 # mm
Identifier "VGA-0"
VendorName "SAM"
ModelName "SyncMaster"
HorizSync 30.0 - 71.0
VertRefresh 50.0 - 160.0
Option "Preferred Mode" "1280x1024"

However, since literally everything else works (I have even tried to install kubuntu to see if another brand of linux would read monitor properties properly - it did not, and the system font was like 5 pixels high, so I went back to openSUSE right away :slight_smile: ) - so, again, since everything works, I would only like to create a xorg.conf that would be as minimal as possible.

So I assume I just need that line about display size to read

#DisplaySize 700 395 # mm

Is this correct? Should the "#"s be used as they are?

But I don’t know how to define the “Identifier”, the results of the xrandr command do not show it.

my Xorg.0.log: SUSE Paste

I tried to use an EDID.exe utility from under Windows XP installed on the same machine (Windows XP and 7 get the size of the monitor correctly, but do not recognize the sound card on my relatively old mobo :), so here Linux is ahead), but the utility hangs, so I don’t know how to read EDID values.

If it helps, my xorg.conf.install is here -

I would be grateful if someone could tell the noob here how her xorg.conf should look like. Thanks in advance. :slight_smile:

The effect you’re experiencing has nothing to do with any Xorg configuration. The TV is over-scanning, so any solution will involve disabling this via the TV menu.

Thanks heaps, it worked. For the slight chance that anyone else might be experiencing the same problem with the same TV, the remote has a button named QUICK, and in the menu that opens, Picture Size should be set to Normal. That solves the overscan problem.

Another question though. When I tried to install Kubuntu, there were more options for screen resolution there beside 1920x1080 and 1280x720.

How do I add additional resolution possibilities (with the preferred one being 1920x1080)?

Maybe it is due to the active graphics driver. I note from your Xorg.0.log, that you’re using the default (open source) nouveau driver. Manual configuration of the Xorg config files is still possible to add any desired display modes (not detected or used by the driver), and new modes can be defined and selected with xrandr as well. However, the simplest improvement you could make, would be to install the proprietary nvidia driver. (That usually allows for more display mode options without any manual tweaking).