Screen poweroff (11.1 and radeon x1950)

Hi everyone,

Fist sorry for what you can read (I am a newbie in openSuse world with a poor english vocabulary…)

I have made this night a net install of 11.1, all work fine: that seems to be a really great distrib, thanks to all contributors :wink:

But a problem appear after a random time after system launched, the screen turn off and the system continue to work… (music play, etc.) Nothing I can do for poweron the screen except a ctrl alt supp… In safemode (like now) there is no problem (even if the screen go black after 5 minutes of inactivity, a mouse move and screen poweron normally).

My screen is correctly recognized, I have don t make any material or x11 changes, i have tried basic updates but nothing seems to correct the problem. The graphic card i recognized correctly too (ati X1950XT) with no 3d acceleration possibility.

The problem appear really randomly (generally between 1 and 5 min. after the computer start)

If someone have a path to try to resolve this problem i will have a great thanks to you.

KDE4? Gnome? Other?

In kde4 check here](

as well as the main power control section - switch off all power save control to the screen.

KDE 4 but problem is same after disabling display power management…

Do you think it’s a window manager problem ? or x11 ? does an install of ati proprietary driver can help ?

does exists an console app for configure x11 ? under Yast,I can’t change anything concerning graphic card except change the resolution…


Is this a laptop chip or a pc graphics card. I’m not an ATI user. Also are you 32 or 64 bit?

ATI PC Card and amd 64 but 32bits version of openSuse

ATI - openSUSE

Yes i tried this three minutes ago :wink: and 3D acceleration is now supported (not very usefull for me :slight_smile: but problem is same…After a computer restart all start fine and the screen suspend at the end of KDE loading (so hight res. work fine and x11 start…)

For me it seems to be a horizontal/vertical refresh frequency problem but screen detected is exactly same that my one …

So i’m a bit lost, thanks for your help again.

Edit: and I can’t try with gnone ! (only 200MB left on this partition, another potential source for my problem ?)

I doubt this anything to do with X.

Power Management settings need to be explored thoroughly!! What version of kde4? Is it the base install 4.1.3 or have you gone to the Factory 4.2.2?

Might be worth checking that powersave (a kde3 app) is not installed.

I have seen other posts on a similar line to this recently and I think ATI was involved.

Though you say the problem does not happen with a Failsafe boot?
So find the kernel argument that resolves the issue and add it to the default menu.

Look at /boot/grub/menu.lst
see the additionall kernel arguments in the failsafe boot. Write them down and manually add each one, one at a time to a default boot (You just type it in at the boot screen) Once you find the one that helps, you add it to the menu.lst file

Thanks for your help and sorry for the delay (Many try and some work to do)

So for anyone who have this kind of problem, I’ve tried to run default boot with many options, certains have an effect (with “apm=off noresume nosmp” (I’ve not tried options one by one) the screen standby randomly approximatly between 10 minutes and 2 hour, it’s much better but lightly amazing too…)

Many xorg.conf changes after, KDE was so slowly after loading than I decide to try something else (very bad): format and install ubuntu (:X) and with ubuntu: the monitor stand by at the graphic setup screen…

Try with another screen: problem is same.

Trying another distrib: mandriva 2009.1 rc2. Problem is same, except for one point: The boot CD let set options to the kernel before graphical setup and have a checkbox for desactivate acpi.
(openSUSE have certainly this options but i have tried net install via USB key…)

So with that and “apm=off noresume nosmp” as options: live install goes fine, I added this parameters to grub for default line, reboot OK.

Tried if something i more slowly due to params: I tried 3D desktop (:sarcastic:), all work very fine (for the moment).

So i keep this distrib (work fine and I need a linux now wathever it is) but I’m sure that the same thinks can be done with openSUZE.

Concerning the problem i don’t have the time to search the real cause but under windows no problem like that with nochange on acpi or whatever…