Screen not locking

Just installed Leap15.3, with standard KDE install, and having issues with the screen not locking.
Have checked settings>Workspace Behaviour>Screen Locking and all is good, but never locks, even after hours.
Think I have had this before with something…??
Can lock manually (Meta + L).
How do I check, etc.
Thanks.

What happens when, you hit the Windows/Meta key?

  • Does the KDE Plasma Application Launcher appear?

Recipe here – <Plasma/Tips - KDE UserBase Wiki.

Then, there’s this ArchWiki recipe –

don’t use “World Map” as wallpaper type in KDEs locking screen configuration.

The Meta key by itself does nothing, but Alt-F1 opens the menu…?
Screen locking still doesn’t work… (only manually).
Thanks.

Check to see if it’s been disabled in the activity settings:

https://paste.opensuse.org/view/raw/5fd0726f

Edit: Serious Senior Moment - Forget that, totally wrong, Sorry.

That’s set to: “Do not use special settings”…?

Those settings aren’t relevant to your problem, as I realized a few minutes after my post, hence the edit. Apologies once more.

If it’s not working, make sure your Application Launcher (“Start Menu”) widget has a global shortcut like Alt+F1 set (you can’t assign it directly to Meta, but it will open with Meta if another shortcut is assigned).

  • Right Click the KDE Icon → Configure Application Launcher
  • Keyboard Shortcuts tab → Shortcut: Alt+F1

Possibly the KDE Plasma Global Shortcuts are maybe corrupted –

  • Walk-through the Global Shortcuts and check that within the System Settings the Global Shortcut for “Lock Session
    ” is <Meta+L> with, <Ctrl+Alt+L> as the alternative – the default settings.

Reset the settings to make sure that nothing has been corrupted …
The setting for the Application Launcher possibly also needs to be reset …

Have checked all I can think of…
When at the login screen, appears to work.
Power (screen off) command is also only working at the login screen (or if I set to minimal time and watch…)
Really frustrating, as I go away for hours, come back and the screen is still on.
As I say, can lock manually (Meta + L), but power saving never kicks in…
Is there a log I can chase up with this? Have checked journalctl, but nothing obvious, although do get a few of these:

Jun 19 12:05:33 boss kwin_x11[3030]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 10234, resource id: 39846944, major code: 18 (ChangeProperty), minor code: 0
Jun 19 12:05:33 boss kwin_x11[3030]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 10239, resource id: 39846945, major code: 18 (ChangeProperty), minor code: 0


Thanks.

Have you tried holding the mouse over the power manager tray icon (looks like a battery)? It sometimes tells me which process is preventing screen blanking.

Nope, doesn’t help.
I can have nothing running, except basic system stuff, and still doesn’t kick in…