Screen locking is driving me nuts...please help!

Hi everyone!

Ok, this issue is a real show stopper for me (I am using XFCE btw).

Whenever my system is idle, it goes into a mode where all screens (have 3 of them; two external and one laptop. My laptop is Lenovo W520) become black.

I can use the mouse and can move the cursor around screens. No problem.

However, no keys bring up the login box.

The only thing I can do at that point is to press Ctrl+Alt+F1 to switch to a virtual console, login, and reboot.

Any ideas? Any help would be great, as it is really killing my productivity.

1 Is this a hybrid graphic notebook? (Intel+NVIDIA)? If so what drivers?

2 Have you set any screen saver or screen lockers??

Thank you for your reply. You are correct – I do have an Intel and an Nvidia cards

Below is the output of my lspci:


00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
**00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)**
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port Mobile SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
**01:00.0 VGA compatible controller: NVIDIA Corporation GF106GLM [Quadro 2000M] (rev a1)**
01:00.1 Audio device: NVIDIA Corporation GF106 High Definition Audio Controller (rev a1)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N + WiMAX 6250 [Kilmer Peak] (rev 5e)
0d:00.0 System peripheral: Ricoh Co Ltd PCIe SDXC/MMC Host Controller (rev 08)
0d:00.3 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 PCIe IEEE 1394 Controller (rev 04)
0e:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

My XFCE4 power settings are as follows:

Display: Blank after 10 minutes when plugged in
Put to sleep after 10 mins when plugged in
Switch off after 60 mins when plugged in

Screensaves Preferences:

Screensaver: Blank screen (changed it to Floating XFCE4 just now to test)
Regard computer as idle after 79 mins

**Enable lock screen: **Yes
**Lock with screensave: **Yes
Lock screen after the screensaver is active for: 0 minutes

This is called Optimus and is a bit of a pain. You won’t be able use the NVIDIA without installing either suse-prime or bumblebee .Note bumblebee is depreciated AFAIK

try setting the Lock screen after the screensaver is active for: 0 minutes up a bit it may be a screen lock problem

Thank you! Just to make sure that I understand your suggestion correctly: are you saying I should disable the option “lock screen with screensaver”?

Are there any downsides to using opensuse prime?

Increase the time from 0 say 10 min or so if this works you may want to disable the lock or make it very large. Just making suggestion I don’t run XFCE myself

Thanks, when I disable locking the issue seems to go away. Is there any good way to get locking to work that does not have this issue?

Report a bug

https://en.opensuse.org/openSUSE:Submitting_bug_reports