Screen goes black during installating 12.2

I had been trying to install 12.2 using the dvd install method.

While going to the installlation menu. The linux kernel loads then a loading screen appears then, suddenly the screen goes black. Nothing happns for next 30min. I reebot the laptop then.

I have tried all the kernel settings.

Check installation media, Rescue System, Firrmware test all lead to the same result.

Even text mode installation didn’t work.

The memory test shows error at random number generation test. I don’t get it why would 4GB DDR3 memory will show error.

My system configuration: Acer V3-551G laptop
Insyde H2O BIOS (Insyde website shows H2O as UEFI) NB: No options in BIOS setup to turn off UEFI

If you have a GPT formatted hard drive, you may need to boot the openSUSE DVD in uef mode. What is on your hard drive now, do you know? For help on GPT have a look here:, GPT info appears halfway through the article. Further, you may need to use the kernel load option nomodeset. I have a bash script that works with the new Grub 2, though I can’t say I have worked with UEFI, GPT and the need to use nomodeset all at the same time. This bash script would require a system that will boot and a network connection to download but does not need a desktop to load.

GNU Grub2 Command Help/Config Editor - Version: 1.91 Edit Blog Entry:

Thank You,


Now that shouldn’t happen, and that doesn’t sound good.

Did you drop your laptop on the floor?

Did that laptop run under windows before, and if, what about running windows now?

Do you still have a warranty for your laptop?
Then send it back.

If not: you could unplug and replug your RAM modules to make sure that this is not a result of problems with contacts.
Not usual perhaps, but still a possible cause.

Good luck

Of course, my windows 7 is running perfectly normal. I posting using the same laptop.

Did you run a media check to see if you have a good burn? Also what video?

Try entering nomode set in the option box

In any case you need to know if the drive is GPT formatted. If so you will need to use a DVD not the CD to actually install

On 2013-02-08 00:16, ratzi wrote:
> Hi,
> vish_99;2525361 Wrote:
>> The memory test shows error at random number generation test. I don’t
>> get it why would 4GB DDR3 memory will show error.
> Now that shouldn’t happen, and that doesn’t sound good.

There have been reports of some versions of memtest showing errors where
other versions show none. There is a bugzilla on that, I believe.

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Hmpf !

OK vish_99,
did you try to boot your installer DVD in UEFI mode, as advised by jdmcdaniel3 ?
That should become possible by entering the BIOS setup before the booting from the DVD acutally takes place.

It may be even better (!!), if you could try to boot from a Linux live CD (openSUSE, or GParted, or …),
in order to post the output of the command line tool parted -
i.e. after having booted from the live CD: become root, then, in a terminal, call ‘parted’, say ‘print’, then say ‘quit’,
and then copy the output from that terminal, and post it here.

Good luck

Wrong order, sorry.

Boot live CD.
Open a terminal.
Become root by saying ‘su -’ (if needed, the root password usually is available from the web page providing the image of the live CD).
Call ‘parted’.
Say ‘print’.
Then say ‘quit’.
Copy the output, and paste it to a text file accessible by your windows 7.
Then post here.


The black screen is due to the installer trying to use the default resolution on
your machine. Which it can’t handle!?
The same failure has been encountered installing with 16001200 and 14001050.

Try 12801024 or 1152864 if these fail, a lower resolution or text mode.

On one laptop it was also necessary to select
in the boot command line

from the F? buttons at the bottom of the initial install screen.


Earlier i had changed the boot order and moved dvd/cd to first position. So, system automatically booted from dvd.

This time, I used F12:Select boot device method of the bios.

Following options appeared:

  1. Hard Disk
  3. Network Boot

I choose UEFI/EFI DVD/CD method.

Following text appeared.

ELILO boot…done
Loading Linux Kernel…done
(Some more strings of text)

Then screen went black.

The boot sceen (boot through hard disk; installation; rescue sysem…) as in previous case, didn’t appear.

I think so, UEFI is not the problem.

@keellambert the no kms option worked. I’ve successfully installed openSUSE

welcome on board,

have fun

  •  		 			;)

You probably want to install the NVIDIA driver now.