Screen flicker after April 08, 2018 updates

After this morning’s Tumbleweed updates, which I believe included a kernel-default and mesa updates, a “mouse related” screen flicker has appeared. The flicker happens only when I move the mouse cursor and the flicker seems much worse if I pass the cursor over items that have a “mouseover” function, such as animated icons.
I run KDE Plasma as my primary desktop, but I have also been able to produce the flicker when in an LXDE session.
Computer is Ryzen X1800 based. AMD RX480 graphics. I use corded Logitech USB keyboard and Logitech USB corded gaming mouse. There have been no hardware changes of any kind.
I have tried killing and restarting X. I have also tried changing the mouse’s USB port to no avail.
It’s apparently a bug somewhere, but I’m not sure if it’s kernel related; Mesa related, or something else.
I’m using kernel-default 4.16 from today’s update. Unfortunately, any time I update the kernel, I remove the existing kernel in the same process. So I don’t have the option of booting into yesterday’s kernel. I could go back to 4.14 if I need to.

Have the same issue, others have the same:

Here is one of the same, shared bug report:

Good to know. I see that others in that bug report have ASUS motherboards. Might be a firmware problem rather than the kernel itself. Guess I’ll stay in LXDE until the next kernel update.
This bug scared me. After it first appeared, it seemed to cause actual damage. When I would press my power button to boot, the motherboard would instantly go completely dark, like some kind of breaker was active. After a few seconds, it would light back up. It did that several times before it finally decided to initiate boot. I was running BIOS version 6001, which ASUS marked it “beta” AFTER I downloaded and installed it. I re-flashed to an older version and things seem stable again.

If anyone else is affected by this, there is a temporary workaround. Just add: amdgpu.dc=0 to the kernel parameters for boot. I can verify it worked on my machine.

I have the same issue on an AMD R9 380 and I am also using an ASUS motherboard. Hopefully this will get patched with a kernel update soon! It’s a minor annoyance for now. :expressionless:

I’ll give that temporary workaround a shot.

Probably yes:

Once this is in, it should be fixed:

+Mon Apr 16 13:45:34 CEST 2018 -
± Revert "drm/amd/display: disable CRTCs with NULL FB on their

  • primary plane (V2)" (bsc#1089615, bsc#1088902).
    ± commit e881e16

Seems fixed today.