Screen flashing/Blinking after install and update

I have a really weird annoying issue. I have a new ASUS laptop dual booting Windows 10 and Tumbleweed. (Windows is working without issue) When I get Tumbleweed fully installed updated and setup it seems to be working fine. After rebooting it comes up to the login screen and the display starts blinking. It only stops blinking/flashing when the mouse is moved. It does this under all window managers. I tried to install Tumbleweed again from scratch and in the end it does the same thing. I can not track down what causes this. This is completely unusable. It’s like a strobe. I am trying to use this as a development machine and want to use Opensuse but can’t get by this issue.

Has anyone seen this problem? I didn’t find it in any searches.

Thank You

I’m assuming this is some short of graphic card related problem, but first a few things:

  • does this also happen during the login screen?
  • what desktop environment are you using? and are you using a compositor in it?
  • if you go to the tty1 console (ctrl+alt+F1) does this still occur?
  • what graphic card do you have?

Hello, thanks for responding. It is flashing at the login screen and does this on all desktop managers. I am not near this laptop but will get the details later today.
The strange thing is it has no problems after an initial install. Its not until I install everything I need it starts. I don’t know what is setting it off though. Windows has no problem on here.

Thank You.

so the installer is fine, and initially it also is - weird indeed. I’m still curious about the tty console (which I’m expecting to be fine, at least it shoud)

have you tried or did install proprietary drivers?


I’ve notice I’m having the same or very similar issue with my Lenovo ThinkPad Yoga with OpenSUSE Tumbleweed. It started a few days ago. I have gone to a different TTY, and typed for a while in VIM, and didn’t notice any blinking, so it seems to only happen in the GUI. My device doesn’t have any advanced graphics, just running Intel Haswell Mobile, so I haven’t done any driver installs. The blinking is so quick that I can’t tell if it’s the image, or the backlight blinking. I have run Diagnostics, and everything seems fine, as long as I’m not booted into the Linux GUI. I feel like it was after I saw a kernel update come through that this started. And I tried a fresh install just for the fun of it, and still happens. Let me know if I can test/provide anything to help solve this bug. I have a second HDD in the device, so I can put a test install on there, and break stuff if needed!

lspci shows my graphics as: 00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

Running Gnome Shell.

and uname -r shows: 4.6.1-1-default


it’s pretty clear something is wrong with x in your case (at least), if you log in into a window manager without compositing, like gnome classic does this still go on?

Logged in under IceWM (as it was already installed on my system) and I haven’t seen it blink once yet. I’ll keep using it and let you know if that changes. Any idea’s I can try on how to Gnome Shell to work correctly again? Thanks.

Well, spoke too soon. After using it for a while, it seems it is blinking under IceWM as well. Does IceWM use compositing? Should I try any other window managers?

icewm does not, I was hoping it was related to compositing, but it looks like some short of hardware issue, possibly drivers not being fully compatible with the latest kernel (4.6). do you still have a previous version of the kernel in your system?

Sadly no, I do not as I tried doing a fresh install after thinking something must have gone wrong with an update. I’m not sure if @mikehuns]( might still have an older version that he could test. Or is there a way to install an older version of the kernel so I can see if that fixes the problem?

I was able to download and install 4.6.0-1-default rpm from the tumbleweed repo, and install it, and select it at boot, but still seems to keep doing it. Any idea what the kernel version before that was and where I could find it? I’m guessing it’s 4.5.xx? Thanks.

Sorry to keep replying to myself, but I think I found the solution. There is a bugzilla page: which seems to describe the same problem. It sounds like 4.7-rc and I think I saw the patch in the changelog ( for the 4.6.2 kernel, under commit 69205c5c16df0702870179c8419e89cc954bd311. I haven’t tried this patch on my system yet, but I will give it a try in the morning, and otherwise, sounds like a fix is in the pipeline to. I’ll keep you posted, just wanted to share this info that I have found.

Let’s see if kernel 4.7 does do the job, rc or not :slight_smile:

Thanks for the info regarding this issue. I had not had a chance to look at this over the weekend but will try to tonight.

This does not blink at tty console or during bootup at Tumbleweed “logo”

The video card is Intel broadwell?

I installed Kernel 4.7 RC 2 and it’s still broken…

from what I can tell the broadwell chip/gpu does not seem to be fully supported yet, I know skylake was only given support in the latest kernels, plus intel’s drivers seem to be the same found in the package xf86-video-intel, and in tumbleweed has version 2.99. something. if you go to and try to find a more recent one, does it change anything?

I installed the latest possible version out there of the Intel video package. That did not fix the problem but caused other issues as well. Well at this point I once again have to just go back to using Windows only on here because this is unusable.

Thanks for the help.

Not sure about anyone else, but I have received the Kernel Update 4.6.2-1 and it has resolved the blinking issue on my ThinkPad Yoga. Has anyone else tried this kernel, and has it fixed it for you? If not, let me know what your lspci says you have for a graphics card, and I can see if I can figure out a fix. Would love to help someone else keep using OpenSUSE/Linux!

I have a feeling your blinking problem must have been different. This is a constant flashing almost like a strobe. It stops when the mouse curser moves so it does just seem to be a driver thing. Weird it doesn’t start though until after I get all the updates on. Maybe going with Leap 42.1 will actually work because it’s older not the latest. I haven’t tried that. I’m thinking about installing Fedora 24 and see how that works…

The official video according to system utilities is Intel HD Graphics 5500 (Broadwell GT2)

Thank You