Screen Drawing Issues in GNOME

I installed 13.1 RC1 this morning hoping that my screen redraw issues would be kaput from Beta. Sadly, looks like they are still there.

This is with a Lenovo ThinkPad X220. Any help would be appreciated. The files below are quite large, so I’ve just linked to them.

First I have Firefox open and then hide it with Meta-H and this happens (it is persistent as long as I don’t do something else):

Then I hit Meta to bring up Activities and it looks normal:

Open back up Firefox and then try to close it, but the screen stays like this:

I can go ahead and do other things to have the machine “snap out of it”, but I also get a persistent white screen like this:

When I hit the menus at the top, they are strange and don’t completely go away or draw correctly:

But if I get back to Activities and then dismiss it, I get a normal background:

Any help would be greatly appreciated. I did not have this issue in 12.3 with the same laptop (or SLED 11 SP3 for that matter). Also, all of the menus work fine if I have an application like Firefox running. Thanks!

For fun I went ahead and installed KDE just to make sure I wasn’t losing my mind and it wasn’t something easy with the hardware and KDE works flawlessly. No redraw issues at all.

Just thought I’d chime in with some more information.

It doesn’t help that your pictures are all upside down. Can you print your screen using the print screen key on your key board?

I will attempt to get new photos as soon as I can.

Here are some screenshots I took on a fresh GNOME 13.1 RC1 installation doing various things.

Like I said, everything seems to work in KDE and openSUSE 12.3 GNOME and SLED 11 SP3 but not in openSUSE 13.1 RC1 GNOME.


Is the GPU an Intel device, can you post the details from;

hwinfo --gfxcard

What you are seeing has been seen in VM since the driver isn’t that good. GNOME also uses the GPU more than KDE does and is more likely to expose issues.

Not seeing errors in the /var/log/Xorg.0.log or ~/.xsession-errors?

09: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: _Znp.XOuRdvVTkk2
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Model: “Intel VGA compatible controller”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x0126
SubVendor: pci 0x17aa “Lenovo”
SubDevice: pci 0x21da
Revision: 0x09
Driver: “i915”
Driver Modules: “drm”
Memory Range: 0xf0000000-0xf03fffff (rw,non-prefetchable)
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
I/O Ports: 0x5000-0x503f (rw)
IRQ: 44 (14421 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00008086d00000126sv000017AAsd000021DAbc03sc00i00”
Driver Info #0:
Driver Status: i915 is active
Driver Activation Cmd: “modprobe i915”
Config Status: cfg=no, avail=yes, need=no, active=unknown

Primary display adapter: #9

I can try and check the error messages tonight. I am moving between KDE and GNOME right now so I’ll have to do that tonight.

Thanks, you could upload the full log and xsession-errors to SUSE Paste and set expire to never and post back the URL’s please. One of the openSUSE GNOME Maintainers is keeping an eye on the thread…

I will do that tonight. Thanks for helping me.

Here are the two relevant things you asked for:

Xorg.0.log Paste: SUSE Paste
xsession-errors Paste: SUSE Paste

Let me know what else you need. I’ll continue to use GNOME for a while so that I can answer any other questions you might have.

Another “layer” to this is that if I have a program in the “background” (I.E. Firefox running), then things work well as long as they are “layered” on top of that Firefox window. The strange stuff happens when there is no fullscreen window on the bottom of the “stack”.

This from the Xorg.0.log doesn’t look right:

    69.346] (II) LoadModule: "modesetting"
    69.346] (WW) Warning, couldn't open module modesetting
    69.346] (II) UnloadModule: "modesetting"
    69.346] (II) Unloading modesetting
    69.347] (EE) Failed to load module "modesetting" (module does not exist, 0)

A (EE) error is usually bad news, and can be seriously bad news. Don’t recall seeing this error before. That module failed to load.

I use the intel driver (i915) on a lenovo ThinkPad at the same resolution 1366x768. Checked my Xorg.0.log, but its on Tumbleweed (12.3) KDE and it looks like this at the same point in log:

    33.086] (II) LoadModule: "modesetting"
    33.087] (II) Loading /usr/lib64/xorg/modules/drivers/
    33.088] (II) Module modesetting: vendor="X.Org Foundation"
    33.088]     compiled for 1.13.2, module version = 0.8.0
    33.088]     Module class: X.Org Video Driver
    33.088]     ABI class: X.Org Video Driver, version 13.1

My intel driver is 13.1, yours is newer at 14.1; X.Org X Server 1.13.2, yours X.Org X Server 1.14.3; and my kernel-desktop-3.11.4-31.1, yours slightly older at “3.11.3-1-desktop”.

You might just check your install version with KDE to see if you have the error in Xorg.0.log or not.

Thanks, I’ll pull out my 13.1 RC1 install drive and install KDE so that I can take a look at it and report back.

Here are the same pastes from a base KDE installation on the same machine.

Xorg.0.log Paste: SUSE Paste
xsession-error Paste: SUSE Paste

Let me know if you need anything else.

Looks like the same modsetting module isn’t getting loaded in KDE, but I’m imagining that the graphical needs of KDE are more forgiving than GNOME and so maybe it isn’t showing up in KDE like it is in GNOME?

I could, of course, be insane, but that is what I am seeing here. I’ll try installing openSUSE 12.3 to see if I see the same thing with this laptop and report back … again!

No such errors in 12.3 GNOME installation with modesetting. Everything looks like it is working correctly. Also, no xsession-errors either on the machine.

“modesetting” is a graphics driver just like intel or radeon. In fact it is a generic driver like vesa, but with support for KMS.
You don’t need it as you are using the intel driver anyway, but X’s auto-configuration tries to load more than one driver and then chooses to use the best one of those that can be loaded successfully.
On your system it can’t be loaded, that’s why you get this error message. Maybe you don’t have xf86-video-modesetting installed?

I have no idea about your problem, though, but it sure sounds like a graphics driver issue.
Does the problem persist when you add “nomodeset” to the boot options, or boot to “recovery mode” (“Advanced Options” in the boot menu)?

Good check. I ggogled the error message, and a few other distro users had it and sometimes coupled with the other two driver alternatives vesa and fbdev, coincidentally nearly all Gnome 3 users and their Gnome display problems mysteriously sorted themselves. So most of those reports were pretty useless :. There were other desktops involved as well(IIRC), xfce and openbox. Hence the need to check KDE, as I didn’t see it amongst those other reports and it appeared problem free.

In all probability you don’t need that alternative driver, but it’s still unhelpful and misleading for users when X tries to load drivers that are not available and throws (EE) errors.

You could try Gnome with another desktop if available e.g. Mate, but I’m guessing?

But how should X know which drivers are there and can be successfully loaded, if it doesn’t try to load them? :wink:

Anyway, that’s how X’s auto-configuration works for years now.

I don’t care how, upstream or downstream that’s a problem for the devs to solve. Why is the driver not there if it’s required to be automatically configured? If not required, a warning should be sufficient or the program code should be fixed. It’s obviously not an issue for the previous release of openSUSE or X.