Screen Display not working after installing codecs

I went through the regular installation of OpenSuse 11.1 (Gnome desktop) on a Dell Inspiron 1501. Everything was smooth thankfully, got the wireless up and running, etc.

Then I found this great article on how to further enrich your desktop:
The Perfect Desktop - OpenSUSE 11.1 (GNOME) - Page 4 | HowtoForge - Linux Howtos and Tutorials

In section 7.1 of this link, there are URLs from where you can download and install additional codecs, etc, and then some root commands to complete the process. BTW, I started at the beginning of this article by doing each step in the order given.

While the steps described in the article overall were great because of all the tools I was able to add relatively quickly, it caused another problem.

When I followed through with the codec installation, logged back out and in, my screen went blank. The machine was up and running and I could ping it, but no display at all.

Tried rebooting, nothing, then rebooted in failsafe mode, still nothing. During boot, the splash screen is there, but as soon as the progress bar completes to go to the login screen, it blanks out.

So I am looking for tips on what to do short of reimaging the machine from scratch because I have made so many other customizations already.

I tried booting from the OS dvd and attempting various repair options, but it never mentioned anything about repairing the screen display or any drivers for it.

It’s a shame because without these codecs, I can’t really enjoy all the media types on the laptop.

Before you started was your system up to date?

What happens if you press ctrl+alt+F1 at the blank screen, do you get a
console login?

Are you running nvidia or ati drivers?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 0:14, 2 users, load average: 0.03, 0.16, 0.15
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Hello Malcolm,

Thanks for your post. To answer your questions:

  1. The system was upto date - the auto update was up and running and prompted me with available ones, which I installed (all of them).
  2. When I press Ctrl+Alt+F1, I go into console mode
  3. My video driver is indeed ATI - ATI Radeon XPRESS 200M 5975 (PCIE) to be exact.

One peculiar thing I noted when I bring up the ‘Graphic Card and Monitor’ window from Control Center, is that for the monitor/screen type, it was showing a Samsung. Which was odd. So I changed, tested, and confirmed it to be a Dell 1501 (Digital), which was an available option.

Perhaps now installing the codecs will work? A bit afraid to try that now.

Any tips/ideas?


I would say your kernel got updated along the way, there are threads on
how to install the ATI driver in the forums (just search :wink: )

In the interim at the console login and then;

sudo -i
init 3
sax2 -r -m 0=radeon
init 5 && exit

That should get you started in a GUI again until your sort out the
correct driver. Unfortunately I’m an nvidia/intel user…

If that radeon doesn’t work I think there is radeonhd? Else last resort
use vesa.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 23:48, 3 users, load average: 0.26, 0.34, 0.22
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Thanks Malcolm, will give that a try and post back what happens.