Screen display issues after upgrade 15.4->15.5

Upgrade went well. Screen display not so well.

My hardware:

  • Kernel: 5.14.21-150500.55.12-default arch: x86_64 bits: 64 compiler: gcc*
  • v: 7.5.0 Desktop: KDE Plasma v: 5.27.4 Distro: openSUSE Leap 15.5*
  • Info: quad core model: Intel Core i7-3770 bits: 64 type: MT MCP*
  • arch: Ivy Bridge rev: 9 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB*
  • Speed (MHz): avg: 2455 high: 3251 min/max: 1600/3900 cores: 1: 2061*
  • 2: 3193 3: 2286 4: 1789 5: 3251 6: 2152 7: 1662 8: 3246 bogomips: 54278*
  • Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx*
    Device-1: AMD Turks PRO [Radeon HD 7570] vendor: Dell driver: radeon
    v: kernel arch: TeraScale-2 bus-ID: 01:00.0 temp: 35.5 C
    Display: x11 server: X.Org v: with: Xwayland v: 22.1.5 driver: X:
    loaded: radeon unloaded: fbdev,modesetting,vesa dri: r600 gpu: radeon
    resolution: 1680x1050~60Hz
    API: OpenGL v: N/A renderer: N/A direct render: N/A

The Screen image:

I’m using 1680x1050x60hz. HDMI connection. I’ve tried a new 32" monitor and my older original 22" monitor. I’ve tried various resolutions & refresh rates.
Notice upper right corner seems chopped off, lines at the bottom of the screen which I am guessing belong at the top.

Looking for suggestions. Thanks

That actually looks like the new default background for Leap 15.5.

You are right, that the top seems chopped off. And those lines near the bottom of the screen might be a little too low, so perhaps something is chopped off at the bottom.

Install and run glmark2 and note the result. Then uninstall xf86-video-ati and xf86-video-all and restart Plasma or reboot. Run glmark2 again and compare result. I’m guessing the top will no longer be cut off, but the score will be lower.

Thank you. Also, I started playing with the plasma wallpaper settings and my selected wallpaper is ‘image’. Switching to other options shows that the display is probably ok and that the graphics at the bottom of the display are intentional. I’ll try your suggestions but at this point I am satisfied that the default image that was installed just confused me. All’s well that ends well.

Actually, glmark2 does not run. That said, merely changing the desktop wallpaper from an ‘image’ to a photo and back to the default ‘image’ caused the upper R corner to correct itself and move to what appears to be a better position. The colored lines on the bottom is what confused me, I thought they were an indication of a video driver issue.

Here is my glmark2 run:

libGL error: MESA-LOADER: failed to open r600: /usr/lib64/dri/ undefined symbol: amdgpu_query_video_caps_info (search paths /usr/lib64/dri, suffix _dri)
libGL error: failed to load driver: r600
libGL error: MESA-LOADER: failed to open swrast: /usr/lib64/dri/ undefined symbol: amdgpu_query_video_caps_info (search paths /usr/lib64/dri, suffix _dri)
libGL error: failed to load driver: swrast
Error: glXCreateNewContext failed
Error: CanvasGeneric: Invalid EGL state
Error: main: Could not initialize canvas
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  43
  Current serial number in output stream:  44

If I run it w/ sudo it outputs one line:

 sudo glmark2
[sudo] password for root: 
Error: main: Could not initialize canvas

Anyway, I’m now satisfied that there is nothing wrong and I’ll probably change my desktop wallpaper to a solid color.
Thanks for both of you for the quick reply. I was a bit freaked out when I first saw this.

I believe your upgrade is incomplete, probably WRT Mesa. I have a similar installation that has no problem running Glmark2:

# inxi -SGaz
  Kernel: 5.14.21-150500.55.12-default arch: x86_64 bits: 64 compiler: gcc
    v: 7.5.0 parameters: root=/dev/sda7 noresume consoleblank=0 net.ifnames=0
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 7
    dm: LightDM v: 1.32.0 Distro: openSUSE Leap 15.5
  Device-1: AMD Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] vendor: Dell
    driver: radeon v: kernel alternate: amdgpu arch: TeraScale-2 code: Evergreen
    process: TSMC 32-40nm built: 2009-15 pcie: gen: 2 speed: 5 GT/s lanes: 16
    ports: active: DP-1,DVI-I-1 empty: none bus-ID: 01:00.0 chip-ID: 1002:6779
    class-ID: 0300 temp: 55.5 C
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: modesetting dri: r600 gpu: radeon display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3600x1200 s-dpi: 120 s-size: 762x254mm (30.00x10.00")
    s-diag: 803mm (31.62")
  Monitor-1: DP-1 pos: primary,left model: NEC EA243WM serial: 
    built: 2011 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 519x324mm (20.43x12.76") diag: 612mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 640x480
  Monitor-2: DVI-I-1 pos: right model: Dell P2213 serial: 
    built: 2012 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
    size: 473x296mm (18.62x11.65") diag: 558mm (22") ratio: 16:10 modes:
    max: 1680x1050 min: 720x400
  API: OpenGL v: 4.5 Mesa 22.3.5 renderer: AMD CAICOS (DRM 2.50.0 /
    5.14.21-150500.55.12-default LLVM 15.0.7) direct-render: Yes
# rpm -qa | grep -i mesa | sort

Mine has both 64 & 32 bit files. Maybe I have a long forgotten 32bit app but who knows, I’ve been updating this box since OpenSuse v13.x.
I notice some of these files have a different build than you. The other thing is this Dell has an onboard Intel video card which I am not using (IIRC, disabled in bios) plus a plugin video card that I am using. It was configured this way by Dell.
Thanks for your suggestions.

 rpm -qa | grep -i mesa | sort

Mine come 100% from standard repos. Yours are a mixture of standard (32bit) and Packman (64bit, except for demo-x). I think they should all come from the same repo, but it could be Packman’s are broken, or yours is lacking some dependency.

The other difference is I’m using the modesetting DIX. xf86-video-ati is not installed here, but I would address the Mesa difference first.

There’s also non-zero possibility the failure is specific to the difference in our Radeon models, or kernel-firmware-radeon is needed but not installed.

I found I have some locked packages. Some of these were from years ago when I found them causing problems.

 sudo zypper ll

# | Name                   | Type    | Repository | Comment
1 | Mesa-dri-nouveau       | package | (any)      | 
2 | google-roboto-fonts    | package | (any)      | 
3 | kernel-firmware-amdgpu | package | (any)      | 
4 | kernel-preempt         | package | (any)      | 
5 | kernel-preempt-devel   | package | (any)      | 
6 | libdrm_amdgpu1         | package | (any)      | 
7 | libdrm_amdgpu1-32bit   | package | (any)      | 
8 | virtualbox-kmp-preempt | package | (any)      | 

The 3 preempt packages are from a repo I no longer have enabled.

# cat /usr/local/bin/zypseo
zypper --no-refresh se -si | grep 'tem Pac' | grep -v plication

I use the above miniscript to help me ensure locked packages don’t interfere with progress by keeping obsolete packages installed, or blocking required new ones. I don’t think your locks should be causing a problem, but sometimes dependencies aren’t what a mere user would expect. Multiple Google fonts are hard requirements of multiple packages, though no specific font should ever be, so a roboto lockdown could easily cause interference unless choosing to “break” (the ego of) the requiring package(r). Some kernel-firmware-* have inexplicable interdependencies, so could also be blocking. So could libdrm_amdgpu1. Check what “System Packages” you have installed. After a fresh update, there should be none.

cat /usr/local/bin/zypseo
cat: /usr/local/bin/zypseo: No such file or directory

The zypper cmd gives me a long list but I don’t really know how to interpret it.

I just read a post about amdgpu firmware and it fixing a problem for the poster so I’ll go ahead and update those blocked packages, except the preempt packages.

Thanks for your advice.

/usr/local/bin is for self-made scripts intended for most users. I created /usr/local/bin/zypseo. If you wish to have one, do the same.