Screen corruption on KDE 4.2 with Java application

Hi all,

KDE 4.2 was doing very good until yesterday when I tried to update JDonwnloader (a download manager running under Java). the KDE environment freezes completely and the only possible solution is the Power button :\ I haven’t found much info on this, that’s why I’m posting the problem. I’m using nvidia drivers (180.51) and KDE 4.2.3 (Release 1).

Has anybody experimented this? Does anybody knows how to solve it?
Thank you very much for the help!

It’s hard to tell if you are able to actually use your desktop or not?

If necessary can’t you just remove the application.
How was it installed? Then we may be able to help.

Yes Yes, sorry! Once I restart I can enter the desktop and use it without any problem. I can also uninstall the application, it was installed from a .jar file. I was just wondering if there was any possible fix to be able to use the application on KDE 4.2.3.

Thanks for your reply and sorry for the lack of info at the beginning.

If an application is started from a terminal you will often see an indication of the problem in the output as the application starts, but if your system freezes at this point it will not be much use to you. Unless anything is in the .xsession-errors file in /home (hidden files)

Plus there are loads of options for download managers. What do you need it for?

Hi again!

When starting the application from a terminal, everything goes OK until the moment of the crash… then of course I cannot see anything. If I have a look at the xsession-errors, I really don’t understand much of it :\ (…hehe, sorry) but at the very end it shows an error:

Application::crashHandler() called with signal 6; recent crashes: 1
startkde: Shutting down…
klauncher: Exiting on signal 1
KCrash: Application ‘kwin’ crashing…
Fatal Error: Accessed global static ‘KGlobalPrivate *globalData()’ after destruction. Defined at /usr/src/packages/BUILD/kdelibs-4.2.3/kdecore/kernel/kglobal.cpp:114
Unable to start Dr. Konqi
DCOP aborting call from ‘kded’ to ‘klauncher’
startkde: Running shutdown scripts…
startkde: Done.

I noticed that the problem is composite, if I disable composite on xorg.conf I can run the app. without any crash… but I would like to keep the effects…

JDownloader is a mannager for links stored on megaupload, rapidshare, etc. Maybe I should wait for some fix from them or wait for KDE4.3

Thank you very much!

Just drop the effects, it’s not worth the hassle.

yup, I think that’s the point :frowning: I also tried what it says in the NVidia section of the OpenSuse website:

Under: "Application freeze or crash when compositing/3D effects enabled

“…nVidia drivers after 169.xx introduced a new option named UseCompositeWrapper. Put it in the device section of your xorg.conf: Option “UseCompositeWrapper” “true” and enable compositing again. Restart your X server. Your applications should now not freeze or crash any longer.”

…but no way :frowning:

I’m Fedora user and i’m too having same problem with KDE but its okey with Gnome there is no problem.