screen brightness kde 4

the screen seems pretty dark on my new 11.2 64bit install, but there is now kpowersave etc so how can i increase the brightness of the screen?

thanks :slight_smile:

there seem to be a couple of settings in the poewr management thing at the bottom, but if i turn the brightness up, it doesn’t get brighter and as soon as i click off of it, and then open the manager up again the brightness is set to minimum again. it’s quite annoying.

any ideas anyone?

well, just in case someone was watching this thread, or may read it with a similar problem in the future, i solved the problem by rebooting the pc (although logging out should work) and then before logging in click on session at the bottom, it was blank oddly instead of ‘default’ but i clicked on kde and it booted in just as bright as it should be.

strange, but it’s done the trick!

I had an issue with this and the solution for me was switching kernel from Desktop to Default.

Power management is Powerdevil, now integrated in the base system for kde4.

well if the problem comes back and won’t go away that’s what i’ll do. thanks for the pointer.

Ross.

In an HP Pavillion dv6232 with oS11.2/KDE4.3.3, when on battery the screen stays at maximum brightness, and fn keys won’t work to decrease it. Kernel installed was the desktop flavor, changing to standard apparently makes no difference.

This worked with oS11.1 (and oS11.0 IIRC) on this same laptop.

Any suggestion will be greatly appreciated, I’m at a loss on this.

My issue was kind of the opposite. I always had Min brightness at login, but I could use my Fn keys to Max it. The Management slider still showed Min though.
I’m not sure of a solution for you.
What does the Power Management section show? I guess you can adjust in there either.
What happens if you use acpi=off in the kernel at boot.

Yast’s PM module wasn’t installed by default, after including it, it shows a very simple choice of standard, economy and a couple other roles. Either std or economy make no difference. As far as I could see this is just a frontend to /etc/pm-profiler configs, which doesn’t seem to deal directly with the on-power/on-battery switch.

acpi=off (tried with the desktop kernel) boots to the command line with an error message form X: Failed to load module “nouveau” :O. The default kernel installation (through yast) also reinstalled one of the two nvidia packages, don’t recall which. I suppose this may be a mixup from the installer, but if so is easy to fix. Anyway it boots normally (with nvidia logo and 3D). glxinfo says 3d vendor is nvidia, although sysinfo:/ says driver is nv (it isn’t!), and that since the start, not because of the new kernel.

On KDE settings>advanced, PolicyKit authorization has a setting for laptop panel brightness under org.freedektop>hal>power-management. I added my user (nobody and console are already there) but no joy.

This thing is a huge show-stopper for me, as I need I use the laptop a lot in flight. Probably part of the universal conspiracy of inanimate objects against me…

What about manually editing the config file in .kde4/share/config

Just to confirm:

# hwinfo --gfxcard | grep Driver
Driver: "nvidia"
Driver Modules: "nvidia"
Driver Info #0:

Nothing wrong in powerdevilprofilesrc and powerdevilrc that I can see. There are specific settings for reduced brightness and such.

I think (wild speculation, really) that oS11.2 may be seeing my laptop as a desktop, permanently on power, even if the battery monitor works as it should. I hoped that switching the kernel would solve it, but not.

I suppose this will be fixed eventually, I’ll see if there’s a bug report on it.

One idea: I also installed gnome (and xfce) to experiment a little. Gnome has a power management app IINM, I’ll try that.

One idea: I also installed gnome (and xfce) to experiment a little. Gnome has a power management app IINM, I’ll try that.
Let us know how you get on:)

gnome power settings also doesn’t work :frowning: I suppose the problem lays deeper…

obs: the gnome energy usage graphics and info (specially for the battery) is cool! :slight_smile:

I would go down the bug report road…

Thank you for helping, caf.

This seems to be a bug in X. I’ll follow up here:

How to change brightness of monitor on HP Pavilion and 11.2? - openSUSE Forums

How do you switch the kernel from Desktop to Default? I was wondering about that and don’t recall a prompt when I was installing to control that?

Software Management search kernel

Delete kernel-desktop
mark to install kernel-default
(reboot)

N.B: If you have any drivers etc / apps compiled against the current kernel, you will need to re-do them (eg: manual nvida or Virtual Box)

after installing 12.1 i’ve got the same problem, but have yet to be able to fix it. the screen is on its lowest brightness setting and no changing the slider to brighter on the battery monitor settings makes a difference.

any ideas!!!

please help!

thanks

Start a new thread and explain your problem clearly