Screen blank after suspend to ram

Hello All

      I have a new laptop and I just got suse loaded on it. However I cannot resume from suspend to ram (i.e. closing the lid). I can hibernate no problem. I managed to track the problem down to the display failing to start up during the resume phase. Basically before I suspend I have an open terminal where I can type commands. Then when I resume I can type commands into that terminal. From this I was able to determine that the system resumes, it will play sound and execute other commands... so it seems that the only problem is that the screen doesn't start up properly. I don't really know how to fix this, so I am hoping I can get some help here. Thanks!

Some info about my system:

I have the Intel HD Graphics 620

linux-g6s6:/home/mike # /sbin/lspci -nnk|  egrep 'VGA|3D|Display' -A3

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:5916] (rev 02)
        Subsystem: CLEVO/KAPOK Computer Device [1558:2410]
00:08.0 System peripheral [0880]: Intel Corporation Skylake Gaussian Mixture Model [8086:1911]
        Subsystem: CLEVO/KAPOK Computer Device [1558:2410]

linux-g6s6:/home/mike # /usr/sbin/hwinfo --gfxcard

08: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.378]
  Unique ID: _Znp.F69MGszUw87
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel VGA compatible controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x5916 
  SubVendor: pci 0x1558 "CLEVO/KAPOK Computer"
  SubDevice: pci 0x2410 
  Revision: 0x02
  Memory Range: 0xde000000-0xdeffffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  I/O Ports: 0xf000-0xf03f (rw)
  IRQ: 255 (no events)
  Module Alias: "pci:v00008086d00005916sv00001558sd00002410bc03sc00i00"
  Config Status: cfg=no, avail=yes, need=no, active=unknown

Primary display adapter: #8

Also lsmod shows that the i915 module is loaded.

Sounds like a back light problem search here for back light there are many threads that may apply

Interesting, as the lspci and hwinfo output clearly show that it is not

What do you have for: cat /proc/cmdline

Thanks a lot for helping me out…

mike@linux-g6s6:/sys/class> cat /proc/cmdline 

BOOT_IMAGE=/boot/vmlinuz-4.4.36-8-default root=UUID=aaf59666-51ea-4fe5-aed1-993a344f597b ro nomodeset CPUFreq=no resume=/dev/disk/by-uuid/160ced5a-342f-4bca-b481-2fd526d358f1 splash=silent quiet showopts

mike@linux-g6s6:/sys/class> lsmod | grep i915

i915                 1318912  0 
drm_kms_helper        155648  1 i915
drm                   393216  2 i915,drm_kms_helper
i2c_algo_bit           16384  1 i915
video                  40960  1 i915
button                 16384  1 i915

I have been reading about various backlight problems as well…

I should add that I have confirmed that I cannot adjust screen brightness so I think maybe the problem is with backlight… I am looking into how to start fixing these problems…

I have also removed nomodeset and CPUFreq=no from my boot options. That was something I needed to get the install media to work properly

Good – now you’ll get the kernel driver to load.

Have a look at “man intel”, regarding the backlight option for the xorg driver … (provided you’re using intel, as opposed to the modesetting xorg driver)

Hello folks

     Thanks for the advice and help so far.

     So in SuSE on my machine the backlight interface does not show up in /sys/class/backlight/. That directory is empty. From what I read that means there is a problem with the BIOS or drivers or kernel. 

Now this laptop I bought from System76 ( It was delivered with Ubuntu pre-installed and in that installation everything worked. So I decided to recover that installation (from a disk image) to see any differences.

They both use the same kernel version. The difference was they use the i915_bpo module. In this installation /sbin/lspci properly reports that the i915_bpo is being used and /sys/class/backlight/ contains a intel_backlight folder with all the controls. So it seems this i915_bpo is the missing link.

So I did some research. It turns out that this was custom developed by Ubuntu. They backported some new features into this driver. Also I read that kernel 4.4 does not support Kaby-Lake processors fully (I have i7-7500U). However 4.5 or maybe one of the newer ones do support these processors. So it seems a matter of trying to get old software to work on new hardware and I just have to wait for the next release of openSuSE.

Let me know what you think. Is there something I am missing. Is there still something that I can do?


not sure id wait for the next release, just install the latest kernel for 42.2, or install tumbleweed. except for lots of updates TW is fantastic and remarkably stable.

Ah, yes, so it is. I should have spotted that, but the skylake in the lspci output likely through my little brain off track. See this thread for your available openSUSE options:

Looking at the release plan it appears I will have to wait nearly a year to get 42.3… That is too long.

I have never used a rolling release version… I always thought that was more for people who wanted bleeding edge. I have always opted for the discrete releases because I figure they are more stable… I will not have 3rd party modules or VM’s so I think it would not be too annoying for me. Could you tell me what kernel version TW is at? Does it support Kaby-lake?


Hi Tyler

Thanks for sharing that… glad to finally find a thread that matches my problem… By the information there I think I could probably get an updated graphics stack working. I also noticed that Intel has a whole website ( devoted to Linux support and has tools for updating the graphics stack and other things… Personally I try to do as much as possible through Yast though. However it is nice to see companies supporting Linux more and more.

I will give SuSE another try… but that will have to wait for the weekend. I think what I will do is get a dual boot with Ubuntu/Suse so the computer is still usable while I try to get SuSE to work. More on the next weekend.