Screen blank after login

Just installed 11.4. First effort with OpenSuse but have previously used Ubuntu on another machine. Installation went great. After I log in the screen goes blank with just a mouse cursor, everything else is black. Boots okay in recovery mode.

This is a dual boot with Windows XP. Machine boots into windows as expected. HELP!

Gnome or KDE?
Nvidia or ATI?
I’m assuming proprietary drivers since it’s a first boot.

A quick fix might be to add “nomodeset” to your boot commands.

On 08/08/2011 01:46 AM, El Duderino wrote:

> This is a dual boot with Windows XP. Machine boots into windows as
> expected. HELP!

see here: http://tinyurl.com/23mgej6


DD Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

Desktop is KDE.
Video card is Intel, but it will be replaced as soon as my new one arrives from NewEgg in about three days :slight_smile:

Am able to login with “nomodeset” but the graphics are really bad with no system tray on the lower right side of tool bar.

Seems like a graphics driver+GPU combo problem. Posting the output of this command will help Us help You :slight_smile:

/sbin/lspci -nnk

Please use code tags for posting the output back here in order to make it more readable. Here’s a tutorial on how to do this :
Posting in Code Tags - A Guide

Best regards,
Greg

With intel graphic hardware, using ‘nomodeset’ disables the kernel mode setting (which is supposed to help to automatically configure X for one’s graphic card - not working in your case) and it also (if there are no other edits in place) forces the loading of the primative but very compatible ‘fbdev’ graphic driver.

Can you also, in addition to glistwarns request of providing output of:


/sbin/lspci -nnk | grep VGA -A2

(or give the entire ‘lspci -nnk’ if desired) also open with an editor the file /var/log/Xorg.0.log and copy its contents and post its contents to SUSE Paste and click on ‘create’ and then post here the URL that it provides.

Its possible, in conjunction with the boot code ‘nomodeset’ we can force the loading of either the nominal ‘intel’ graphic driver or the older ‘intellegacy’ graphic driver by a judicious edit to the /etc/X11/xorg.conf.d/50-device.conf, but before speculating with such recommendations it would be helpful if we knew more, and hence those information requests.

00:00.0 Host bridge [0600]: IntelCorporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-HubInterface [8086:2560] (rev 01)        Subsystem: Dell Device[1028:0160]
        Kernel driver in use:agpgart-intel
00:02.0 VGA compatible controller[0300]: Intel Corporation 82845G/GL[Brookdale-G]/GE ChipsetIntegrated Graphics Device [8086:2562] (rev 01)
        Subsystem: Dell Device[1028:0160]
00:1d.0 USB Controller [0c03]: IntelCorporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller#1 [8086:24c2] (rev 01)
        Subsystem: Dell Device[1028:0160]
        Kernel driver in use: uhci_hcd
00:1d.1 USB Controller [0c03]: IntelCorporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller#2 [8086:24c4] (rev 01)
        Subsystem: Dell Device[1028:0160]
        Kernel driver in use: uhci_hcd
00:1d.2 USB Controller [0c03]: IntelCorporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller#3 [8086:24c7] (rev 01)
        Subsystem: Dell Device[1028:0160]
        Kernel driver in use: uhci_hcd
00:1d.7 USB Controller [0c03]: IntelCorporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller[8086:24cd] (rev 01)
        Subsystem: Dell Device[1028:0160]
        Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: IntelCorporation 82801 PCI Bridge [8086:244e] (rev 81)
00:1f.0 ISA bridge [0601]: IntelCorporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge[8086:24c0] (rev 01)
00:1f.1 IDE interface [0101]: IntelCorporation 82801DB (ICH4) IDE Controller [8086:24cb] (rev 01)
        Subsystem: Dell Device[1028:0160]
        Kernel driver in use: ata_piix
00:1f.3 SMBus [0c05]: Intel Corporation82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller [8086:24c3](rev 01)
        Subsystem: Dell Device[1028:0160]
        Kernel driver in use:i801_smbus
00:1f.5 Multimedia audio controller[0401]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97Audio Controller [8086:24c5] (rev 01)
        Subsystem: Dell Device[1028:0160]
        Kernel driver in use: Intel ICH
01:05.0 Modem [0703]: Intel CorporationFA82537EP 56K V.92 Data/Fax Modem PCI [8086:1080] (rev 04)
        Subsystem: Dell Device[1028:1000]
        Kernel driver in use: serial
01:09.0 Ethernet controller [0200]:Broadcom Corporation BCM4401 100Base-T [14e4:4401] (rev 01)
        Subsystem: Dell Device[1028:8127]
Kernel driver in use: b44
00:02.0 VGA compatible controller[0300]: Intel Corporation 82845G/GL[Brookdale-G]/GE ChipsetIntegrated Graphics Device [8086:2562] (rev 01)        Subsystem: Dell Device[1028:0160]
00:1d.0 USB Controller [0c03]: IntelCorporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller#1 [8086:24c2] (rev 01)

That tells us your graphic hardware, … an 845G.

It does not tell us why it failed. Thats why I asked for:

Since I do not have that information, I am speculating below …

Plus, you also noted “Boots okay in recovery mode” … Do you mean you are booting with the liveCD/DVD with a recovery mode ?

I also noted:

I recommend you install the program midnight commander (mc) if it is not already installed. This program provides you a friendly way to edit text files if you are caught in a full screen text mode. In such a case, just type ‘mc’ (either as a regular user or with root permissions, dependent on the permissions of the file you wish to edit) and then follow the easy to use menu of the function keys of the editor.

Now you could try to disable automatic recognition of the driver and force it to a setting. … you can do that with the ‘intel’ driver by editting (with root permissions) the /etc/X11/xorg.conf.d/50-device.conf file so that it reads:


Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  Driver "intel"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

EndSection

and then save that and restart you PC (if in a text mode) with root permissions


shutdown -r now

and when restarting type the ‘nomodeset’ boot code when booting (type it in the 1st splash menu such that it appears in the options line with a space between it and whatever other option is in the options line) and see if that will boot X window. If it does not work with ‘nomodeset’ then try without ‘nomodeset’.

If neither works, then reboot with FailSafe and this time instead try with the ‘intellegacy’ driver by editting (with root permissions) the /etc/X11/xorg.conf.d/50-device.conf file so that it reads:


Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  Driver "intellegacy"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

EndSection

and then save that and restart your PC and when restarting type the ‘nomodeset’ boot code when booting (type it in the 1st splash menu such that it appears in the options line with a space between it and whatever other option is in the options line) and see if that will boot X window. If that does not work try without ‘nomodeset’.

If neither works, then reboot with FailSafe and this time instead try with the ‘vesa’ driver by editting (with root permissions) the /etc/X11/xorg.conf.d/50-device.conf file so that it reads:


Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  Driver "vesa"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

EndSection

and then save that and restart your PC and when restarting type the ‘nomodeset’ boot code when booting (type it in the 1st splash menu such that it appears in the options line with a space between it and whatever other option is in the options line) and see if that will boot X window. If that does not work, then try without ‘nomodeset’.