Screen backlight is not working after nvidia installation


I am new to opensuse. I have a problem with screen back-light. Since I installed nvidia driver my “brightness control” in power management is not working. I have searched over the Google but didn’t find complete information particularly for Opensuse. Any help will be of great value.

Here is the info about my system.
Opensuse 12.2 kde 64bit, Nvidia GF 420M.

In your search, did you read this recent thread about a similar issue in this very forum:


Thanks for the reply. Yes i read the post and I have read in my places that adding this line "Option “RegistryDwords” “EnableBrightnessControl=1” will help. But I don’t know where is this file “/etc/X11/xorg.conf.d/50-device.conf” and how to open and edit it. In the post that you mentioned, it is not clear how to do it.

Would you kindly tell me how to do it in Opensuse 12.2?

What system(s) did you use before openSUSE? Any other linux distribution, MS Windows perhaps?

You need to know how to use the file manager, to find that file, on KDE that is Dolphin. “/etc/X11/xorg.conf.d/50-device.conf” shows the path to the file, starting with the root directory (folder), the first “/”. If and when you locate the file named 50-device.conf, clicking on the file’s icon will open the default editor “Kwrite”. You use that editor to make the changes described in the other post.

If you haven’t done that before, you will need to learn some basics before trying to change configuration files, or you may mess up your system. So if you tell us which operating system you used before, we can suggest appropriate reading material if necessary. :slight_smile:

I am unable to find “/etc/X11/xorg.conf.d/50-device.conf” this file.

Yes I am new to Linux. I have used windows all of my life. So would be nice if you can mention some useful material.

Man, just open terminal. Type the following. You can paste by pressing CTRL+SHFT+V and copy by pressing CTRL+SHFT+C on the terminal.

$ file /etc/X11/xorg.conf.d/50-device.conf
/etc/X11/xorg.conf.d/50-device.conf: ERROR: cannot open `/etc/X11/xorg.conf.d/50-device.conf' (No such file or directory)

Are you getting the same error? If yes then I presume you should create this file.

$ mkdir -p /etc/X11/xorg.conf.d
$ touch /etc/X11/xorg.conf.d/50-device.conf

You can open the file by typing the following:

$ sudo nano /etc/X11/xorg.conf.d/50-device.conf

It will be empty if it didn’t exist.

or use Kate for a KDE text editor:

$ sudo kate /etc/X11/xorg.conf.d/50-device.conf

I’ll let the gurus’ take you further on what to do.

Two things you should be aware of when looking for files, that may still be different to Windows:

  1. Linux file names are case-sensitive, so e.g. X11 requires a uppercase “X”, not “x”.
  2. Linux uses “/” (not “” as in windows) to separate files and directories/folders.

Your system comes with Documentation as html files, including a Start-Up guide, see the list index at /usr/share/doc/manual/opensuse-manuals_en/index.html

If you cannot find it, here is the online version of that startup guide at openSUSE Wiki:
openSUSE 12.2: Start-Up

For file management, see 2. KDE Quick Start in 1. Installation Basics, and for Working with files and directories see 17. Shell Basics in IV The Bash Shell. You will see plenty of other useful things to learn there. :slight_smile:

A quick search on the web shows that this card has Optimus support, now that alone, the manufacturer has to enable it too, doesn’t mean the system is an Optimus one, but better check that. What’s the output of the following command:

/sbin/lspci | grep VGA