Scratch sound in Opensuse 11.1

When I watch movies in Smplayer there is a scratchy sound sometimes. All volume is on the 100% and I follow the guide on Scratching sounds in opensuse 11.1 - openSUSE Forums but nothing works.
If the volume is not on the 100 % I can’t hear anything or just very little.

I also makes the scratch sounds when I see movies on youtube or playing games,

What is wrong and how do I fix this???


Volume at 100% will cause distortion/scratching. You need to lower the volume control setting

How much??? I can barely hear anything at 100 %.

Only the person who hears the actual audio can say “how much”. :expressionless:

Did you also go to YAST > HARDWARE > SOUND > OTHER > VOLUME and move both the PCM and Master (and speaker/surround if applicable) volume controls there up to a reasonable (but distortion avoiding) levels. Then close YaST. And then go to your mixer (kmix in kde and alsamixer/amixer in Gnome) and move the PCM, Master (and speaker/surrournd if applicable) to levels where the volume is ok and the distortion not present?

Yep, but the same. And then I can’t hear anything.

Is there any chance your hardware is too new to have a good implementation for it in alsa?

My computer is about a year og a half year old. Is that to new???

I just installed VLC player and the sound is loud enough. Maybe its only SMplayer.

The problem I find with vlc player is when one moves up the sound higher than about 25% volume, one will get severe distortion. … At least its that way on my PCs.

Too new ? I don’t know. How can I ? I do not know what hardware your 1.5 year old computer has. Nor do I know your PC’s software configuration.

You could run a diagnostic script that checks your PC’s hardware and software audio configuration, and then the script uploads a summary of the configuration to the internet and provides you a URL where the information is located. Thus you can then pass the URL to others who can check your configuration.

To run that script in openSUSE-11.1, with your PC connected to the Internet, type “su” to get root permissions (enter root password when promted) and type:
That will ask you if you wish to update the script. Select YES. The script will update.

Then run the script a second time:
/usr/sbin/alsa-info.shand this time let the script complete properly. When it finishes it will give you a URL (where your PC’s configuration for audio is stored). You can then pass the URL to people who are trying to help you. hope this helps.

I note kernel with a ‘Realtek ALC660-VD’ hardware audio codec.

You could try forcing alsa (upon booting) to a fixed configuration, instead of relying on the autoprobe of alsa to properly configure your hardware. You can do that by applying edits to your PC’s /etc/modprobe.d/sound file, selecting ONE AT A TIME items from this list from the HD-Audio-Models.txt files for alsa:

	  3stack	3-jack
	  3stack-dig	3-jack with SPDIF OUT
	  6stack-dig	6-jack with SPDIF OUT
	  3stack-660	3-jack (for ALC660VD)
	  3stack-660-digout 3-jack with SPDIF OUT (for ALC660VD)
	  lenovo	Lenovo 3000 C200
	  dallas	Dallas laptops
	  hp		HP TX1000
	  asus-v1s	ASUS V1Sn
	  auto		auto-config reading BIOS (default)

So lets say you start by trying “3stack” from that list. Then open your /etc/modprobe.d/sound file (with root permissions) and add this as the first line in that file:

options snd=hda-intel model=3stack

Note you can edit that file in gnome by typing

  • in gnome: gnomesu 'gedit /etc/modprobe.d/sound’

  • in kde: kdesu 'kwrite /etc/modprobe.d/sound’
    entering root password when prompted for a password.

and then restart your alsa sound driver by typing **su -c ‘rcalsasound restart’ **and enter root password when prompted. Then start your mixer (kmix in kde and alsamixer/amixer in gnome) and test your sound. Be certain to apply all the techniques noted in this thread (such as YaST/mixer).

That may actually break your sound. No worries if it does, or if it does not help. In which case change “3stack” in the /etc/modprobe.d/sound file with “3stack-dig” and try again (restart alsa, restart mixer … ) … If “3stack-dig” fails, keep trying, one by one, going thru each item in the list.

Do any of those help improve your volume ? Note your mixer controls may change with different options, and that may make a difference.

I tried every combination and it was the same. Scratch sounds everytime.

IMHO then your only alternative if you stay with openSUSE is to either

  • tune it out with your mixer (ie optimize better the settings); or
  • update to the latest version of alsa and see if that helps

When I search on the alsa site for the ALC660VD I see some updates, but none of them reference improvements for ‘scratchy sound’
Search results - AlsaProject

There is guidance here for updating alsa:
Alsa-update - openSUSE

… but since I can not hear your sound, and since I run into an incredible number of Linux users who over exaggerate minor problems, my advise is to live with the “scratching” and try to tune it out.

Well… Thanks for trying anyway :slight_smile: