scons does not see g++

Hello, all. I am a relatively new Linux user, and this is my first time using the software “scons.” I am trying to compile a piece of software called “Mitsuba Renderer.” It is set up so that in the main directory, there are folders of various source code and libraries, and an SConstruct file as well as a Config file. It’s all set up as near as I can tell, and I have g++ installed in the form of the “gcc-g++” and “gcc48-g++” packages. When I run scons in the directory, it tells me it could not find g++ and could not compile a “simple c++ fragment.” It also tells me to look in config.log for more information. Here is an excerpt from it that may contain the error:

g++ -o .sconf_temp/conftest_0 .sconf_temp/conftest_0.o -lboost_system -lboost_filesystem -lboost_thread -ldl -lm -lpthread -lgomp
/usr/lib64/gcc/x86_64-suse-linux/4.8/../../../../x86_64-suse-linux/bin/ld: cannot find -lboost_system
/usr/lib64/gcc/x86_64-suse-linux/4.8/../../../../x86_64-suse-linux/bin/ld: cannot find -lboost_filesystem
/usr/lib64/gcc/x86_64-suse-linux/4.8/../../../../x86_64-suse-linux/bin/ld: cannot find -lboost_thread
collect2: error: ld returned 1 exit status

I’m not sure how to interpret that, but it seems like it’s looking in entirely the wrong place for gcc, which is located in my /usr/bin if I’m not mistaken.
Running that command in console returns the same error message. Running “which g++” “prints/usr/bin/g++”, which, upon inspection, is a 742 KiB executable. So there appears to be no problem there. When I simply write “g++” it prints that I didn’t give it a file to compile, which seems fine.

So now we get to the core of it: Do any of you out there have experience with scons-wrangling? And if so, what have your solutions to this problem been?

An advance deposit of thanks to anyone who can help me!

It finds g++ fine, it can’t find the boost development files…

zypper in boost-devel

The ntry re-running your test compile.

Thank you, Sir Malcolm! that definitely was the problem. After installing that (and a few more libraries that the software was more clear about wanting), it got to the point where it really went into compile time. However, after a moment of telling me exactly what it’s doing in language I don’t understand, it says this: “collect2: error: ld returned 1 exit status”.
I’m wondering if this is still something to do with scons, or if I’m off in mitsuba’s territory and cannot be helped.

Thanks again!

Oh, it also said “/usr/lib64/gcc/x86_64-suse-linux/4.8/…/…/…/…/x86_64-suse-linux/bin/ld: cannot find -lfftw3_threads”, which I will definitely now investigate. Upon investigations, it appears to have to do with “FFTW”, a fourier transform library. I am continuing to investigate.

Aha! The package “fftw3-threads-devel” included what I needed. Awesome!

Here’s the full package of thanks.

Good job :slight_smile: a search on part of the offending package either via zypper or YaST should narrow things down to a ‘devel’ package :wink: