scim and ibus don't work in gtk programmes in opensuse 11.4

I installed opensuse 11.4rc2 using a dvd, in virtualbox and then in a laptop, but in these two cases, I can’t call out the input bar of scim and ibus in gtk input box or textareas(for example, url input box in firefox), but they(scim and ibus) work well in qt apps.
I 've checked the md5 of the dvd “openSUSE-DVD-Build0012-x86_64.iso”
and I 've


and I got “scim”

what can I do to solve this problem?
Thanks a lot !!!

Bumping this thread - I’m having the same problem.

I installed openSuSE 11.4 with KDE desktop. I installed ibus, ibus-gtk, ibus-qt. In KDE apps (yakuake, kate, dolphin…) ibus worked fine. In GTK apps (firefox, pidgin,…), I can’t seem to select ibus as input method.

I checked after reboot:

  • both QT_IM_MODULE and GTK_IM_MODULE is “ibus”; XMODIFIERS is “@im=ibus”.
  • I set sysconfig/system/environment/language/INPUT_METHOD to “ibus”.
  • There seems to be nothing related to imput method in gconf-editor.

In openSuSE 11.2, after installing IBUS and restarting, I automatically had ibus setup as systemwide default input method, such that in a GTK app, when right-clicking a text box and choose “Input method”, I see “System (ibus (…))” . But now it appeared as “System (simple)”.

Any help would be appreciated. I wanted to switch to something newer than 11.2 long ago :frowning:

Okay, I finally found out what went wrong: It seems like gtk-query-immodules-2.0-64 did not get run (I’m on x86_64).

So what I did:
make sure ibus, ibus-gtk and ibus-qt are installed (replace those with scim if you’re going to use scim).
sudo su
gtk-query-immodules-2.0-64 > /etc/gtk2.0/gtk64.immodules (on 32bit systems: gtk-query-immodules-2.0 > /etc/gtk2.0/gtk.immodules)
open the file and check to make sure “ibus” is in there (or “scim”). Reboot.

gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules

Thank you for posting that. It worked! There was a small typo there, missing the “-” in /etc/gtk-2.0, but that was easy to figure out.

11.4 might be usable for me now. :slight_smile:

Thanks a lot , I 've tried your advices, but it still not works~

I have same problem with you in Opensuse 11.4.And I found the solve New: can not use input method framework(scim and ibus) in GTK programs - - ArchiveOrange
You only install gtk2-immodule-xim and remove other gtk2-immodule-*** packages to solve this problem.
Good luck!

I do not use scim or ibus. But I can use fcitx in any gtk2 program now after installing gtk2-immodule-xim:)


I applied what are suggested within this thread but I can not use ibus within Firefox. But, ibus and Chrome works like a charm. This post is made with Chrome.

I faced the issue of ibus and LibreOffice. But updating the LibreOffice solve the issue. I think of making Chrome as primary web browser on my box.