scientific python tools in OBS education


Partly in response to a post asking what apps users use…

I installed 11.2 milestone 4 a few weeks ago, overall it works quite well. I use python for some numerical scientific work. Some packages, namely numpy, scipy, matplotlib, are not in the standard opensuse repos.

From searching the build service, these things seem to be in either the Education or Science … what do I call them, repos? factories?

Either way, from the Ed. repo I could install numpy and scipy, but matplotlib required the package “python-numeric.” This sounds like a red herring - numpy should take care of this. There’s no option in the yast dialog to ignore it. I posted this as a bug to something that seemed specific to the Ed. repo, but never got a reply. I forget where I posted it.

Anyway, I added the Science repo and can do matplotlib. It works! I tried running a python script that uses some spline interpolation routines, loaded with:

from scipy.interpolate import splrep, splev

I get an error relating to lapack, which you can essentially get with:

from scipy import linalg

The error is:
ImportError: /usr/lib64/python2.6/site-packages/scipy/linalg/ undefined symbol: clapack_sgesv

The first time I got this, I found out from yast that lapacklib was installed, but not lapack itself. I installed lapack. No difference.

Perhaps there’s a “real bug,” or lapack needs to be installed before scipy is?

Either way, help w/ these issues would be appreciated.

Thanks, Dave


Not that it should matter since it looks like you are using some error packages, it maybe for debian or other linux, not for suse.

limewire for linux.

Hi Dave

Sorry for the long time without an answer, but it looks like I’m currently the only developer in the Education area looking at the forum from time to time. I’ve subscribed the Forum now, so I should get an Email once new Threads arrive…

Just call them “repositories”… :wink:

Thanks for bringing this up! I fixed this for the next rebuild of the python-numpy package now, so this bug should be solved.

There are sometimes too many ways and too many people where you can post a bug:

Please open a new bug on Welcome to education’s Bugzilla - this looks really like a bug as it shouldn’t make a difference when you install lapack at all.

With kind regards,

Now here a best insurance service is now offering to students. They can earn many from. View the website and know more here.