Scanner issue

Running openSUSE 11.2 with HP All-in-one 3055 printer/fax/scanner attached through network.
Using hplip package.

Printer works just fine.
Scanner did work for quite some time, however it stopped working after some update about a month ago (using only opensuse update repo).

When doing hp-scan I get following error:
Using device hpaio:/net/HP_LaserJet_3055?ip=
Opening connection to device…
error: SANE: Error during device I/O (code=9)

Checking all the logs I can think of I can’t figure this one out. Tried newer hplip package fom HP site same issue (I have two systems, on one I’ve tried the new driver, on one only using opensuse update repo …both same issue)

Any pointers where the problem could be?
The scanner worked for several months just fine. Some update broke it I guess.

Have you tried deleting it and then reinstalling it?
Haven’t used hplip network scanners, but I know that for printing, you need to set the preferences in cups before hplip gets the correct settings.
It may be the same for scanning.

Yes, I’ve tried re-installing hplip multiple times.
And yes, you need to register it with CUPS. I’ve done printer and scanner configuration via Yast. As I mentioned this used to work just fine until approx. a month ago when some update made was applied. Since then I’m trying to fix it.

Have you tried a search of the forum for problems with hplip and scanning for your printer?
You may find that there was a version change in hplip, so try a previous version by searching at:

If nothing else works, you can compile your own hplip from the source on the hplip website. Just make sure you uninstall the opensuse version first.
Sorry, can’t be any more help - I don’t have a network scanner.

Having done a google on the error, I see quite a few reports of this error and it’s not confined to hp only.
If you try scanning as root, does it work? If so, then you have a permissions problem.
Try the suggestion here:
and it may give some clues.

Thanks for the pointers.
I’ve tried all as root and also I’ve compiled new hp drivers from source. All gives same error.

When trying the debug as described in one of the links you’ve provided it finishes OK

[hp] sane_get_devices will finish with Success
device `hpaio:/net/HP_LaserJet_3055?ip=' is a Hewlett-Packard HP_LaserJet_3055 all-in-one
[hp] sane_exit called
[hp] hp_destroy: global.is_up = 0
[hp] sane_exit will finish

Yet, when I try to scan as root or normal user I get this

Using device hpaio:/net/HP_LaserJet_3055?ip=
Opening connection to device...
error: SANE: Error during device I/O (code=9)

Try this link:

Please read thru the last post by Bruce

Thanks for all the suggestions, I’ve tried all of them …the issue is still there.

I’m going to build a new system without updates to see if I can get this working how it was.

OK, I solved it.

The issue was that SNMP write access on the all-in-one printer was disabled.

I’ve disabled the write while go while tightening the LAN security.

What makes me mad is that nowhere is documented that the SNMP write has to be enabled. I/O error 9 could have been more verbose.

thank you beaujolais
i’m having the same problem in my HP network printer / scanner,
could you please guide me more on the permission procedure,
i’m using ubunut 11.04 (new user), and i don’t know who to do these file permissions.

appreciate your assistance.