Scanner in HP Officejet 4630 all in one no longer working after OSS 15.3 upgrade

The scanner within this printer was working on all OSS through 15.1 until I upgraded to 15.3. I have tried initializing scanner config in Yast.

not configured: Hewlett-Packard HP Officejet 4630 series USB scanner (vendor=0x03f0 [HP], product=0x0000 [HP Officejet 4630 series])
When I go for scanner driver and model selection I choose:
Hewlett-Packard Any all-in-one device : (Package hplip) Driver hpaio may work, but was not tested. (USB-ID 0x03f0:0x0000) [fallback entry for HP all-in-one devices]

The exact driver is not there. But it is still not configured. Upon other > test, I get **“Test not possible, it is only possible to test a detected scanner.” **I tried other > restart detection, still not configured / same result.

Then I tried other > run hp-setup > connection type: USB > the driver window says: “hp:/usb/Officejet_4630_series?serial=CN58C671F105Y0” next > window pops up “detecting scanner,” but it stops, no resulting scanner.

Please help, thanks in advance.

Have you tried to update HPLIP? I had serious problems in getting a brand new HP Officejet Pro 8025e up and running, it is not supported by HP under Linux. Going to and following the instructions gave me a new HPLIP system under 15.3; that solved my problem.

Best regards,
Jan Christian

Upgrade Leap 15.1 -> 15.3 is not supported, only 15.1 -> 15.2 -> 15.3 is possible.