scanner hp scanjet 3570c

Whenever I try to scan documents (OpenSuse 11.1) with any of the available tools (such as scanlite, kooka, or xsane), I can only scan in color. Moreover, the result is basically unusable. I shows a turquoise background of differing intensity at various places. Why isn’t there a possibility to scan black and white, grayscale, etc.? Seems like scanning still is a problem in Linux. Any help (or enlightenment!) would be greatly appreciated! I really don’t want to have to “fall back” to M$-Windows for scanning, but that seems to be the only solution at the moment
Regards
http://forums.opensuse.org/images/smiliesnew/angry.png
H. Stoellinger

By the way, can somebody tell me where the ICM profiles are located (in particular one for my HP 3570c) and what I have to do to be able to start xsane from my “normal” user? xsane only starts from the root user. I suppose this is an issue of access rights. When I start from any user except from “root”, I get the message (translated from German) “Error during colour conversion” and “Error when opening scanner ICM profile”. Thanks for any help.
Regards
H. Stoellinger
Salzburg
:frowning:

For me magenta vertical strips in a scan mean the sensor array is failing. I have an old HP 2200C or something that scans fine the first pass, but from the second on has these stripes. It has to cool down to work again. But in your case it may well be due to wrong decoding, i.e., backend.

My HP 3800 was not supported in OS10.2 and defective in 11.0, so I use the sourceforge backend from a terminal (ended up writing a GUI for it kommander script). You may want to check what’s the backend (the app that does the job) and try it directly.

About the permissions thing, you could try to see to what group your scanner belongs to (it’s not necessarily group ‘scanner’) and add yourself to it.

hi

scanners seem to me to be a continuing issue in OpenSuse: I would say two areas need help:

  1. webcams
  2. permissions issues using USB scanners

have a read at this post

Ubuntu Epson SX400 All in One — Making it work! at bluemonki dot net

I know it is Ubuntu: but it illustrates the complexity of the issues:

OPenSuse has chosen to put scanning access etc into the group

lp

so no scanner group exists in OpenSuse; (unlike nearly other distro)

I have not yet solved the permission issue on our computer!!

I have a workaround:

lsusb

record the dev and bus number

as root issue an order to change permissions but it only works for that log-in; and I am away from the desktop to tell you the exact command !!

What’s the command you are referring to ?

lsusb

tells you what is attached to what; and it may change

so for this log in, if the scanner is attached to Bus 00h Device 00t

the command that worked for me was

su
and enter root password and if I use the # to signify it is now a root command

chmod a+rw /dev/bus/usb/00h/00t

that worked for me with Suse: I could then activate xscan

obviously change h and t to reflect the numbers you get from lsusb

Although I’ m not experiencing quite the same problem, the brand and serial number of your scanner triggers me to response in this thread with two solutions. I hope it is not out of place here?
Permission issues with my HP Scanjet 5300C occur on my system since I first used Opensuse every once-thrice a year, with Opensuse11.0, 11.1 and now 11.2 (with KDE4):

  • Sometimes xsane freezes during scanning as a normal user and it works fine as a root;
  • Sometimes the armature stops moving during the scanning and then it stucks, flashing four or sometimes five times, again when scanning as a normal user. Only a re-power of the scanner could get it out of this dead state. Scanning as root works again fine.
    What helps me out is simply deleting /home/use/.sane. After this and a restart of xsane, I then most of the times can scan as a normal user again. Also a reconfigure with YAST is sometimes needed.
    I’ll guess this confirms that scanning with Linux remains a bit of a complex issue.

You might want to look at the contents of this file:

/etc/udev/rules.d/55-libsane.rules

Hi again,
I have now added my user to group “lp” as suggested and can use xsane. However, these issues still exist:
(1) I can only scan in colour (when sometimes I want to scan black and white or gray-scale)
(2) turquoise stripes are still present. This has DEFINITELY got nothing to do with the scanner array because scanning works perfectly well under Windows/XP.
Scanning obviously is still somewhat of a mystery even in the newest distribution of OpenSuse (11.3). Any new findings on the matter would be much appreciated.
Regards H. Stoellinger-Salzburghttp://forums.opensuse.org/images/smiliesnew/angry.png