Scanner and usbfs

First of, Thank you for reading tho
is post and answering you can.

my Samsung scanner/printer uses a proprietary driver based on usb since it has an usb connection. But this driver relies on the usbfs mounted on /proc/bus/usb. But nothing there. Nada

Then I declared usbfs on /etc/fstab with

usbfs                                      /proc/bus/usb           usbfs  noauto                      0  0

but when I try to mount it with mount usbfs, I get:

mount: /proc/bus/usb: mount point does not exist.

I also tried to mkdir /proc/bus/usb, but no way…

Any idea about what to do ?

Thx again for reading

Update your driver. usbfs was removed from kernel years ago.

Could you give more information about the printer type?

A samsung laser printer/scanner C48x whose latest driver seems to be uld_V1.00.39_01.17.tar.gz /usb and net based)

Since Samsung sold out their printer division to HP, it is not clear whether new drivers will be developed or not.

It doesn’t seem possible. I apparently got the latest available

For the scanner, you could use the following solution:

  1. connect the scanner to your computer
  2. open a terminal and type # lsusb
  3. it should show the ID of you scanner (mine is: Bus 001 Device 005: ID 04b8:1115
    Seiko Epson Corp. XP-342 343 345 Series) 1. under /etc/sane.d create a file called samsung.conf (sudo nano /etc/sane.d/samsung.conf)
  4. in this file, write the following: usb 0x*[first part of the ID]*
    0x*[second part of the ID] *-- mine is usb 0x04b8 0x1115 1. save and exit
  5. under /etc/sane.d open the dll.conf file (sudo nano /etc/sane.d/dll.conf)
  6. make a new line at the bottom of this file and write samsung
  7. save and exit
  8. now you can test if yast recognize your scanner

For the printer, you could try to download the ppd from this webpage: http://openprinting.org/printer/Samsung/Samsung-C48x

The printer is ok, just the scanner makes fuss

that being said I got:
lsusb: Bus 001 Device 004: ID 04e8:347e Samsung Electronics Co., Ltd C48x Series Color Laser Multifunction Printer

and the usb scanner id is also found in xerox_mfp.conf

Made as you suggested, but nothinf happened

What does Yast say?

What is reported by

scanimage -L

Run as user first, then as root (if not found as user).

Ok, finally I got something !

But I still doesn’t understand what was wrong in my previous config since the device was already declared as a xerox stuff. Ok, never mind… It works

Thx for your help

The usual idea is to run the requested command(s) and report back with the actual output.

But I still doesn’t understand what was wrong in my previous config since the device was already declared as a xerox stuff. Ok, never mind… It works

Thx for your help

Ok, I guess from this response that it is resolved.